Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Missing plugins when upgrading Eclipse(Upgrading to latest Eclipse, just about every project is marked in error, but still work)
Missing plugins when upgrading Eclipse [message #1828802] Fri, 19 June 2020 02:37 Go to next message
Paul Morrison is currently offline Paul MorrisonFriend
Messages: 5
Registered: July 2009
Junior Member
I have been using Eclipse for several years, and have quite a few working Eclipse projects. Today I started get errors mentioning aeri, and one of the answers suggested upgrading Eclipse. I am now on 4.16.0, but I get lots of problems and some errors in the log... but all my projects still work (at least the ones I've tried).

Some of the errors involve Jface - does that still exist?

Some of them involve de.jcup - same question...

Finally subversion.subclipse.core.svnnature

How does one upgrade/delete/reinstall Eclipse plugins? The instructions all seem to refer to earlier versions, and I can't seem to find the links referred to.

Thanks in advance,

Paul M.
Re: Missing plugins when upgrading Eclipse [message #1828805 is a reply to message #1828802] Fri, 19 June 2020 05:15 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31230
Registered: July 2009
Senior Member
The aeri servers were shutdown quite some time ago, so perhaps that causing some of the logged problems. The aeri plugins are no longer part of the packages, but if you updated from an older version where they were installed, I don't think they'll get uninstalled as a result of an update.

All the JFace stuff should still be present. JFace and SWT are of course essential for the IDE itself to function. Of course there will be newer versions of them. Do you rely on the target platform simply being the same as what's in the running IDE? I.e., in Window -> Preferences -> Plug-in Development Environment -> Target Platform are you using "Running Platform"? Perhaps a Reload... for that will help update it after an update (though that should happen automatically).

I don't recognize de.jcup. Where might that come from?

With regard to SVN, I believe that parts of the support for that are installed from external (non-Eclipse hosted sources).

It's not so easy to just delete/uninstall plugins. Only via Help -> About Eclipse IDE -> Installation Details and then the Installed Software tab can you uninstall the things listed there; generally features (groups of plugins).

Updating of course involves using Help -> Check for Updates. That of course relies on which Update sites you have enabled as places to look for updates.

Perhaps it's unhelpful to suggest that it's likely just as well to create a new installation using the latest release. That's generally what I do, but then all the IDEs I want have automated setups that use Oomph, so I can easily make a new one anytime I want.

Re: Missing plugins when upgrading Eclipse [message #1828988 is a reply to message #1828805] Tue, 23 June 2020 16:42 Go to previous message
Paul Morrison is currently offline Paul MorrisonFriend
Messages: 5
Registered: July 2009
Junior Member
Hi Ed, Apologies - I couldn't find my question, so I didn't see your response until today! In the meantime, I renamed .metadata, effectively deleting it, and things improved significantly! I still have a jFace problem, so I posted another question, thinking that this one had gotten lost!

So we could close this question (don't see how to do that), and thanks for the feedback! I am now going to look at my other question - thanks again!
Previous Topic:erro ao abrir eclipse
Next Topic:.log error
Goto Forum:
  


Current Time: Sun Jul 05 11:38:14 GMT 2020

Powered by FUDForum. Page generated in 0.02760 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top