Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Unable to install scala in eclipse oxygen version(Unable to install scala plugin in eclipse oxygen version)
Unable to install scala in eclipse oxygen version [message #1828616] Mon, 15 June 2020 09:37 Go to next message
ashwini naik is currently offline ashwini naikFriend
Messages: 3
Registered: June 2020
Junior Member
Hi,

Installed eclipse IDE in ubuntu 16.04 64-bit machine. Going ahead trying to install scala plugin in this. Unable to install it.
I followed below steps:
In eclipse go to Help->Install New Software->Added the link " http://download.scala-ide.org/sdk/lithium/e47/scala212/stable/site" in "Work with" dialog box. Select it and press Enter.
But I get an error stating :
HTTP Server 'Bad Gateway' : http://download.scala-ide.org/sdk/lithium/e47/scala212/stable/site/content.xml
HTTP Server 'Bad Gateway' : http://download.scala-ide.org/sdk/lithium/e47/scala212/stable/site/content.xml
HttpComponents connection error response code 502
and sometimes timeout error.

I even tried installing scala IDE 4.7.x from eclipseMarketplace and run into a similar error:
HTTP Server 'Bad Gateway' : http://download.scala-ide.org/sdk/lithium/e47/scala212/dev/site/content.xml
HttpComponents connection error response code 502.
and sometimes timeout errors as
Unable to read repository at http://download.scala-ide.org/sdk/lithium/e47/scala212/dev/site/content.xml.
Connect to download.scala-ide.org:80 timed out

Is scala plugin website is down?
Re: Unable to install scala in eclipse oxygen version [message #1828617 is a reply to message #1828616] Mon, 15 June 2020 09:43 Go to previous message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 181
Registered: April 2012
Senior Member
Scala IDE is not part of Eclipse Platform, nor is it a project under the umbrella of the Eclipse Foundation.

Please contact the Scala IDE team for any issues: http://scala-ide.org/
Previous Topic:java.lang.IllegalStateException: Workbench has not been created yet.
Next Topic:Is TLS certificate on marketplace site used by 2020-06 self-signed?
Goto Forum:
  


Current Time: Mon Jan 18 17:43:42 GMT 2021

Powered by FUDForum. Page generated in 0.06864 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top