Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Eclipse Web Tools Platform Project (WTP) » Node js 8.10.0 not supported(Getting Message even though there is no Node.js in use)
Node js 8.10.0 not supported [message #1828538] Thu, 11 June 2020 15:13 Go to next message
Tim Lammarsch is currently offline Tim LammarschFriend
Messages: 2
Registered: June 2020
Junior Member
I have recently migrated a Gradle WTP project to Eclipse EE 20.3. Since then, whenever I open up the first html file, it complains that I should upgrade Node.js to 10 or better.

However, I am not using Node.js and I have never actively installed it anywhere. It might stem from some wizard actions, I honestly have to admit that I do not know everything those wizards do. Even more so, I am completely clueless what's actually wrong.

So my first preference would be deactivating Node.js completely for the project, followed by just upgrading to a non-complaining version and be done with it. I would appreciate any help on how to do this. I can also upload some files like build.gradle, but there is nothing about Node.js in there.

Thank you in advance.
Re: Node js 8.10.0 not supported [message #1828549 is a reply to message #1828538] Thu, 11 June 2020 17:57 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3832
Registered: July 2009
Senior Member

The Enterprise Java package as of 2020-03 includes Wild Web Developer, which spins up its support when you open any file type it supports. It is what prompts for node to be installed if it's not, and about incompatible versions if that's what it finds. It's replacing most of the support for JavaScript files in 2020-06.

https://github.com/eclipse/wildwebdeveloper/issues/23 is the closest thing I can find that already exists to track this.


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Node js 8.10.0 not supported [message #1828584 is a reply to message #1828549] Sat, 13 June 2020 09:18 Go to previous message
Tim Lammarsch is currently offline Tim LammarschFriend
Messages: 2
Registered: June 2020
Junior Member
Thank you Nitin, that was exactly the explanation I needed. I ended up installing a newer version of node.js and got rid of the problem.
Previous Topic:Why does 2020-3 WPT Web Page Editor have only a empty tab
Next Topic:Webservice: The service definition selected is invalid.
Goto Forum:
  


Current Time: Mon Sep 21 10:35:08 GMT 2020

Powered by FUDForum. Page generated in 0.04773 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top