Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Restore a project
Restore a project [message #1828458] Wed, 10 June 2020 08:15 Go to next message
Gregory Roche is currently offline Gregory RocheFriend
Messages: 8
Registered: February 2020
Junior Member
Hello everybody,

after restarting my eclipse, I have loosed some elements of the model.

And, in the column view Model Explorer, I haven't the root of the hierarchy.

How can I restore the situation ? Thank you.

index.php/fa/38301/0/

[Updated on: Wed, 10 June 2020 08:18]

Report message to a moderator

Re: Restore a project [message #1828464 is a reply to message #1828458] Wed, 10 June 2020 09:27 Go to previous messageGo to next message
jb tw is currently offline jb twFriend
Messages: 26
Registered: December 2019
Junior Member
Check the naming in the filename.uml and filename.notation

If you file/ project name was old_filename_a and you made a copy and named it NewFilenameB than are the names internally still old_filename_a.
So close the project open the files in notepad++ (or equivalent) search for all old_filename_a and rename them to NewFilenameB, saving and reopen then should everything work (again).

[Updated on: Wed, 10 June 2020 09:28]

Report message to a moderator

Re: Restore a project [message #1828466 is a reply to message #1828464] Wed, 10 June 2020 10:00 Go to previous messageGo to next message
Gregory Roche is currently offline Gregory RocheFriend
Messages: 8
Registered: February 2020
Junior Member

I looked the content of the file uml, and I seem that is empty.

When, I used the local history for restore an old version
and I think that the situation is now ok.

Thank you very much.
Re: Restore a project [message #1828519 is a reply to message #1828466] Thu, 11 June 2020 09:42 Go to previous message
Gregory Roche is currently offline Gregory RocheFriend
Messages: 8
Registered: February 2020
Junior Member
Now, I think that I must resolve this problem.

There is a problem in the Model Explorer.

I can't have the Default Papyrus Viewpoint.

How to change this ? Thank you.

index.php/fa/38315/0/
Previous Topic:How to add part and reference to bdd
Next Topic:tycho-surefire-plugin failed to open Papyrus diagram
Goto Forum:
  


Current Time: Mon Jan 25 00:01:51 GMT 2021

Powered by FUDForum. Page generated in 0.02004 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top