Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » junit plugin update within Eclipse IDE 2019.3(Junit version update)
junit plugin update within Eclipse IDE 2019.3 [message #1827682] Wed, 20 May 2020 15:42 Go to next message
MJ MJ is currently offline MJ MJFriend
Messages: 2
Registered: May 2020
Junior Member
What are the steps to follow to update junit 4 plugin update within Eclipse.

We currently use Eclipse 2019.3 version. The Junit plugin is using junit 4.12 jar
What are the steps we can follow to update the junit jar file to junit 4.13 version?

Any help would be greatly appreciated
Re: junit plugin update within Eclipse IDE 2019.3 [message #1827704 is a reply to message #1827682] Thu, 21 May 2020 07:46 Go to previous messageGo to next message
Noopur Gupta is currently offline Noopur GuptaFriend
Messages: 56
Registered: December 2012
Member
Please use Eclipse 4.15 (2020-03) which includes JUnit 4.13.
Re: junit plugin update within Eclipse IDE 2019.3 [message #1827713 is a reply to message #1827704] Thu, 21 May 2020 15:07 Go to previous messageGo to next message
MJ MJ is currently offline MJ MJFriend
Messages: 2
Registered: May 2020
Junior Member
Unfortunately, we cannot update Eclipse at this point as there are many implications

The question is is there a way to just update junit library?
Re: junit plugin update within Eclipse IDE 2019.3 [message #1830939 is a reply to message #1827713] Fri, 07 August 2020 06:11 Go to previous message
Noopur Gupta is currently offline Noopur GuptaFriend
Messages: 56
Registered: December 2012
Member
To use the JUnit 4.13 library, you need the updated JDT bundles as there were structural changes in this version update. So, just updating the JUnit version will not work.
Previous Topic:Newbie QA: How to remove the previous values and enter new values.
Next Topic:Is Eclipse 2020-06 compatible with Adopt OpenJDK 11
Goto Forum:
  


Current Time: Tue Oct 27 16:38:25 GMT 2020

Powered by FUDForum. Page generated in 0.02163 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top