Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Disable Dark theme on macOS for eclipse products(dark theme)
Disable Dark theme on macOS for eclipse products [message #1827439] Thu, 14 May 2020 14:08 Go to next message
Guillaume Hillairet is currently offline Guillaume HillairetFriend
Messages: 95
Registered: July 2009
Member
Is there a way through properties or other to disable the automatic dark theme selection when macOS is itself set on dark theme.

Our product has plugins that don't support dark theme so I would like the product to be on light theme even if the OS is using a dark theme.

I tried to use org.eclipse.swt.display.useSystemTheme but it did not work.

Thanks.
Re: Disable Dark theme on macOS for eclipse products [message #1827446 is a reply to message #1827439] Thu, 14 May 2020 15:35 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 138
Registered: April 2012
Senior Member
This should be possible by setting the cssTheme property to org.eclipse.e4.ui.css.theme.e4_default
Re: Disable Dark theme on macOS for eclipse products [message #1827535 is a reply to message #1827446] Sun, 17 May 2020 21:55 Go to previous messageGo to next message
Guillaume Hillairet is currently offline Guillaume HillairetFriend
Messages: 95
Registered: July 2009
Member
Thanks for the answer, but I was already using this property. It seems to have no effect. If macOS is set to use dark theme, the eclipse dark theme seems to be activated by default.
Re: Disable Dark theme on macOS for eclipse products [message #1827582 is a reply to message #1827535] Mon, 18 May 2020 17:03 Go to previous message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 138
Registered: April 2012
Senior Member
I don't have macOS available, so I cannot validate. When the option is ignored when the dark OS theme is used, it sounds like a bug. You might get better feedback by creating a bug report for platform UI.
Previous Topic:sha-512 checksum not shown
Next Topic:How to add product logo to "About"?
Goto Forum:
  


Current Time: Sun Jul 12 14:05:31 GMT 2020

Powered by FUDForum. Page generated in 0.02048 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top