Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Specific Xstream version in rcp plugin(Why we still use this specific version of Xstream in jubula rcp plugin)
Specific Xstream version in rcp plugin [message #1827357] Wed, 13 May 2020 17:15 Go to next message
MATOUT abdellah is currently offline MATOUT abdellahFriend
Messages: 1
Registered: May 2020
Junior Member
Hi every one,
I'm using jubula version 8.7 to test a rcp application. For security vulnerability i have to UPDATE the rcp plugin org.eclipse.jubula.rc.rcp_7.0.2.201902270829 , so i need to replace the current version com.thoughtworks.xstream-1.3.1.v201111240924.jar with the new one xstream-1.4.11.jar. i did that, but i got an exception when i trying to launch object mapping.
So my questions are :
* Why the community still use the old version of Xstream 1.3.1 in the latest version of jubula rcp plugin ?
* If I upgrade the version of Xstream 1.3.1 in the rcp plugin, is it enough to work ?

Thanks !
Abdellah

[Updated on: Wed, 13 May 2020 21:59]

Report message to a moderator

Re: Specific Xstream version in rcp plugin [message #1828180 is a reply to message #1827357] Wed, 03 June 2020 10:20 Go to previous message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 215
Registered: March 2012
Senior Member
We are using the version from the orbit repository and this has not been updated yet.
xstream is also located in the jubula.tools jar, so only replacing one place might or might not work.

best regards
Marvin Mueller
Previous Topic:ConnectException on consecutive execution
Next Topic:Jubula not recognising AUT window while running test case
Goto Forum:
  


Current Time: Fri Jul 10 19:28:08 GMT 2020

Powered by FUDForum. Page generated in 0.01752 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top