Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Registering Static Profile - Profile not listed
Registering Static Profile - Profile not listed [message #1827250] Mon, 11 May 2020 13:23 Go to next message
Susanne Fuchs is currently offline Susanne FuchsFriend
Messages: 27
Registered: March 2020
Junior Member
Hi,

I created a profile and want to add some of its elements to a Palette and create diagrams with the profile applied as default. I'm not 100% sure if I'm on the right track, but I tried to create a plugin out of my profile by following the "Registering the Generated Static Profile" instructions here https://help.eclipse.org/2020-03/index.jsp

I created an example diagram in the same Papyrus Eclipse application and tested if I registered it correctly with "Apply registered profile". But my profile is not listed among the registered profiles.

I tried it again with a simple profile and the same settings as in the instructions, but it still doesn't work. I repeated it a couple of times. Could someone please check if I missed something? I included the simple profile in the attachments. I use Eclipse 2020-03 (4.15.0)

Maybe my target "platform:/plugin/com.mylanguage.profile/profile/" in the org.eclipse.emf.ecore.uri_mapping extension is not correct? I don't quite understand the rules this one has to follow.





Thank you for your support!


index.php/fa/38089/0/
index.php/fa/38086/0/

[Updated on: Mon, 11 May 2020 13:27]

Report message to a moderator

Re: Registering Static Profile - Profile not listed [message #1827355 is a reply to message #1827250] Wed, 13 May 2020 16:06 Go to previous messageGo to next message
Ansgar Radermacher is currently offline Ansgar RadermacherFriend
Messages: 281
Registered: March 2011
Location: Paris Saclay, France
Senior Member
I've checkout your profile and it is well shown in the list of registered profiles (but without an icon, define one, as a missing one might cause undefined behavior). Please keep in mind that you only see your plugin in a 2nd Eclipse instance started from the first or if you install it in your current version.

Some things to improve: remove the profile definitions. They are not needed in case of a static profile (and can cause problems). You don't need the ecore profile, if you fill out the native UML "URI" attribute instead of using the attribute of the EPackage stereotype.
Re: Registering Static Profile - Profile not listed [message #1827482 is a reply to message #1827355] Fri, 15 May 2020 14:00 Go to previous messageGo to next message
Susanne Fuchs is currently offline Susanne FuchsFriend
Messages: 27
Registered: March 2020
Junior Member
Hello Ansgar,
thank you for your reply!
You're right, it works when I use another instance! I misunderstood the instruction in a way that I should test it in the same instance, I'm sorry.

And thank you very munch for the other tips!
What exactly do you mean by the profile definitions? The whole "mylanguage.profile" folder with di, uml, notation, and genmodel files? I don't want to delete too much :D
And where can I add an icon to the profile? When I search for it the documentation, I can only find how to add icons to stereotypes.
Re: Registering Static Profile - Profile not listed [message #1827507 is a reply to message #1827482] Sat, 16 May 2020 07:58 Go to previous messageGo to next message
Ansgar Radermacher is currently offline Ansgar RadermacherFriend
Messages: 281
Registered: March 2011
Location: Paris Saclay, France
Senior Member
If you select the profile in the model-explorer, the property view should show a tab called "definition".
It shows the definitions and you can delete them there.
Each time you save the profile, Papyrus asks whether to create such a definition - so it's well possible to accidentally create one or more definitions. In case of a static profile, answer "no" to this dialog.
Re: Registering Static Profile - Profile not listed [message #1827547 is a reply to message #1827507] Mon, 18 May 2020 06:39 Go to previous messageGo to next message
Susanne Fuchs is currently offline Susanne FuchsFriend
Messages: 27
Registered: March 2020
Junior Member
Oh, it's that "In order to apply that profile, it has to be defined" question, now I remember. Thank you for the instruction, I could delete the definitions. :)
Re: Registering Static Profile - Profile not listed [message #1829180 is a reply to message #1827547] Fri, 26 June 2020 12:37 Go to previous message
Susanne Fuchs is currently offline Susanne FuchsFriend
Messages: 27
Registered: March 2020
Junior Member
--- (commented on wrong question)

[Updated on: Fri, 26 June 2020 16:06]

Report message to a moderator

Previous Topic:Validation Plugin, Contraint not executed
Next Topic:Diagram Assistant: Create New Element with stereotype applied
Goto Forum:
  


Current Time: Mon Jan 25 04:32:59 GMT 2021

Powered by FUDForum. Page generated in 0.03560 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top