Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mosquitto » Trying to add a new user in a fresh install
Trying to add a new user in a fresh install [message #1827092] Thu, 07 May 2020 04:22 Go to next message
Mike Dodge is currently offline Mike DodgeFriend
Messages: 2
Registered: May 2020
Junior Member
I am following the tutorial here: https://www .quora. com /How-do-I-set-up-a-Mosquitto-MQTT-server-and-receive-data-from-OwnTracks to install and configure Mosquitto on my Pi4. I've gotten to the part where it says to create the username and password. The command does not work for me.

I type i:
sudo mosquitto_passwd c /etc/mosquitto/pwfile username

And I just get back the Usage text which tells me it didn't take the command correctly.
Apparently I can't include a link to the image, but I have uploaded it to this post.
  • Attachment: Capture.PNG
    (Size: 29.34KB, Downloaded 12 times)
Re: Trying to add a new user in a fresh install [message #1827116 is a reply to message #1827092] Thu, 07 May 2020 12:53 Go to previous messageGo to next message
Roger Light is currently offline Roger LightFriend
Messages: 45
Registered: September 2013
Member
Looking very closely at your image the "-c" looks different to the ones printed in the usage instructions. I think the quora site has replaced the - character with something that is more "correct" in typography, but is wrong here. If you type it yourself without pasting I'm sure it will work.
Re: Trying to add a new user in a fresh install [message #1827136 is a reply to message #1827116] Thu, 07 May 2020 21:12 Go to previous message
Mike Dodge is currently offline Mike DodgeFriend
Messages: 2
Registered: May 2020
Junior Member
Oh my gosh, those are some eagle eyes you've got there!! That was exactly the issue!! I made a comment on that Quora post to help anyone else who comes along in the future and has the same problem. Thank you so much!
Previous Topic: Problems with broker mosquitto
Next Topic:Remote server Pi Mosquitto Problem
Goto Forum:
  


Current Time: Tue Oct 20 09:05:20 GMT 2020

Powered by FUDForum. Page generated in 0.37531 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top