Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » cant upgrade from 4.14 to 4.15
cant upgrade from 4.14 to 4.15 [message #1826681] Tue, 28 April 2020 18:13 Go to next message
under net is currently offline under netFriend
Messages: 6
Registered: March 2014
Junior Member
trying to update from 4.14 to 4.15 fails because certain dependency's can not be satisfied.

I am using the following update sites>
https://download.eclipse.org/releases/2020-03/
http://download.eclipse.org/eclipse/updates/4.14

Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse IDE for Java Developers 4.15.0.20200313-1200 (epp.package.java 4.15.0.20200313-1200)
Missing requirement: Eclipse e4 Workbench 1.11.200.v20200205-1503 (org.eclipse.e4.ui.workbench 1.11.200.v20200205-1503) requires 'osgi.service; (objectClass=org.osgi.service.event.EventAdmin)' but it could not be found
Cannot satisfy dependency:
From: Eclipse IDE for Java Developers 4.15.0.20200313-1200 (epp.package.java 4.15.0.20200313-1200)
To: org.eclipse.equinox.p2.iu; org.eclipse.platform.feature.group [4.15.0.v20200305-0155,4.15.0.v20200305-0155]
Cannot satisfy dependency:
From: Eclipse 4 Rich Client Platform 4.15.0.v20200304-0601 (org.eclipse.e4.rcp.feature.group 4.15.0.v20200304-0601)
To: org.eclipse.equinox.p2.iu; org.eclipse.e4.ui.workbench [1.11.200.v20200205-1503,1.11.200.v20200205-1503]
Cannot satisfy dependency:
From: Eclipse Platform 4.15.0.v20200305-0155 (org.eclipse.platform.feature.group 4.15.0.v20200305-0155)
To: org.eclipse.equinox.p2.iu; org.eclipse.rcp.feature.group [4.15.0.v20200305-0155,4.15.0.v20200305-0155]
Cannot satisfy dependency:
From: Eclipse RCP 4.15.0.v20200305-0155 (org.eclipse.rcp.feature.group 4.15.0.v20200305-0155)
To: org.eclipse.equinox.p2.iu; org.eclipse.e4.rcp.feature.group [4.15.0.v20200304-0601,4.15.0.v20200304-0601]

Re: cant upgrade from 4.14 to 4.15 [message #1826699 is a reply to message #1826681] Wed, 29 April 2020 07:27 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31151
Registered: July 2009
Senior Member
I've see this specific failure sometimes when resolving a target platform and then when I try again without changing anything it works. So I wonder if this problem is consistently reproducible in your scenario?

Perhaps also you might try to disable the 4.14 or use instead http://download.eclipse.org/eclipse/updates/4.15
Re: cant upgrade from 4.14 to 4.15 [message #1826707 is a reply to message #1826699] Wed, 29 April 2020 10:06 Go to previous messageGo to next message
under net is currently offline under netFriend
Messages: 6
Registered: March 2014
Junior Member
I've done it about 10 times now with same error.

I have added 4.15 repo and disabled 4.14 but same result
Re: cant upgrade from 4.14 to 4.15 [message #1826717 is a reply to message #1826707] Wed, 29 April 2020 11:26 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31151
Registered: July 2009
Senior Member
It's very strange regardless because this unit which is in the 2020-03 repo should satisfy that requirement:
<unit id='org.eclipse.equinox.event' version='1.5.300.v20191001-1333' singleton='false' generation='2'>
  <update id='org.eclipse.equinox.event' range='[0.0.0,1.5.300.v20191001-1333)' severity='0'/>
  <properties size='8'>
    <property name='df_LT.bundleVendor' value='Eclipse.org - Equinox'/>
    <property name='df_LT.bundleName' value='Event Admin'/>
    <property name='org.eclipse.equinox.p2.name' value='%bundleName'/>
    <property name='org.eclipse.equinox.p2.provider' value='%bundleVendor'/>
    <property name='org.eclipse.equinox.p2.bundle.localization' value='plugin'/>
    <property name='maven-groupId' value='org.eclipse.equinox'/>
    <property name='maven-artifactId' value='org.eclipse.equinox.event'/>
    <property name='maven-version' value='1.5.300-SNAPSHOT'/>
  </properties>
  <provides size='9'>
    <provided namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.equinox.event' version='1.5.300.v20191001-1333'/>
    <provided namespace='osgi.bundle' name='org.eclipse.equinox.event' version='1.5.300.v20191001-1333'/>
    <provided namespace='java.package' name='org.eclipse.equinox.internal.event' version='0.0.0'/>
    <provided namespace='java.package' name='org.eclipse.equinox.internal.event.mapper' version='0.0.0'/>
    <provided namespace='osgi.identity' name='org.eclipse.equinox.event' version='1.5.300.v20191001-1333'>
      <properties size='1'>
        <property name='type' value='osgi.bundle'/>
      </properties>
    </provided>
   <provided namespace='osgi.service' name='org.eclipse.equinox.event_1.5.300.v20191001-1333-1' version='0.0.0'>
      <properties size='1'>
        <property name='objectClass' value='org.osgi.service.event.EventAdmin' type='List'/>  <!--------------THIS RIGHT HERE PROVIDES THE objectClass  ------>
      </properties>
    </provided>
    <provided namespace='osgi.implementation' name='osgi.event' version='1.4.0'/>
    <provided namespace='org.eclipse.equinox.p2.eclipse.type' name='bundle' version='1.0.0'/>
    <provided namespace='org.eclipse.equinox.p2.localization' name='df_LT' version='1.0.0'/>
  </provides>
  <requires size='7'>
    <required namespace='java.package' name='org.eclipse.osgi.framework.eventmgr' range='1.1.0'/>
    <required namespace='java.package' name='org.eclipse.osgi.util' range='1.1.0'/>
    <required namespace='java.package' name='org.osgi.framework' range='1.6.0'/>
    <required namespace='java.package' name='org.osgi.service.event' range='[1.3.0,1.5.0)'/>
    <required namespace='java.package' name='org.osgi.service.log' range='1.3.0'/>
    <required namespace='java.package' name='org.osgi.util.tracker' range='1.5.0'/>
    <requiredProperties namespace='osgi.ee' match='(&amp;(osgi.ee=JavaSE)(version=1.7))'/>
  </requires>
  <artifacts size='1'>
    <artifact classifier='osgi.bundle' id='org.eclipse.equinox.event' version='1.5.300.v20191001-1333'/>
  </artifacts>
  <touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>
  <touchpointData size='1'>
    <instructions size='1'>
      <instruction key='manifest'>
        Bundle-SymbolicName: org.eclipse.equinox.event&#xA;Bundle-Version: 1.5.300.v20191001-1333
      </instruction>
    </instructions>
  </touchpointData>
</unit>
I'm not sure what to suggest other than installing 2020-03 fresh. :-(
Re: cant upgrade from 4.14 to 4.15 [message #1826718 is a reply to message #1826717] Wed, 29 April 2020 11:59 Go to previous messageGo to next message
Juuso Vilmunen is currently offline Juuso VilmunenFriend
Messages: 2
Registered: April 2020
Junior Member
I had the same problem and it started working after I added 2019-09 update site to the list. I also have 2019-12 there.

In the "update details" window it says "Eclipse Java Development Tools" would be updated to 3.18.100.v20190916-1045 version.
Re: cant upgrade from 4.14 to 4.15 [message #1826738 is a reply to message #1826718] Wed, 29 April 2020 16:09 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31151
Registered: July 2009
Senior Member
Note though that the 3.18.100.v20190916-1045 is not the 2020-03 release version. That would be 3.18.300.v20200305-0155

One underlying issue here is that the p2 format changed though that was quite some time ago now. Likely that's somehow involved....
Re: cant upgrade from 4.14 to 4.15 [message #1826762 is a reply to message #1826718] Thu, 30 April 2020 06:29 Go to previous messageGo to next message
Juuso Vilmunen is currently offline Juuso VilmunenFriend
Messages: 2
Registered: April 2020
Junior Member
After updating and restarting eclipse, I got more updates but they failed. I removed the 2019-09 update site and now everything seems to be updated.

Juuso Vilmunen wrote on Wed, 29 April 2020 11:59
I had the same problem and it started working after I added 2019-09 update site to the list. I also have 2019-12 there.

In the "update details" window it says "Eclipse Java Development Tools" would be updated to 3.18.100.v20190916-1045 version.

Re: cant upgrade from 4.14 to 4.15 [message #1826790 is a reply to message #1826762] Thu, 30 April 2020 14:08 Go to previous message
under net is currently offline under netFriend
Messages: 6
Registered: March 2014
Junior Member
adding 2019-09 update site to the list solved the problem for me too, I really wish everything was under one update site as it seems to be pot luck on which ones are required.
Previous Topic:How to Always Show Scrollbars in Eclipse Oxygen
Next Topic:Help for a complete newbie
Goto Forum:
  


Current Time: Tue May 26 14:17:53 GMT 2020

Powered by FUDForum. Page generated in 0.03142 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top