Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Open declaration is not working in feature files(Open declaration is not working in feature files)
Open declaration is not working in feature files [message #1826404] Fri, 24 April 2020 12:35 Go to next message
Doris Li is currently offline Doris LiFriend
Messages: 2
Registered: April 2020
Junior Member
I am using Eclipse 2020-03.
Working with Java + Cucumber

In feature file(.feature),try to open declaration,neither F3 or Ctrl+click works for me

Can someone please help?
Thank you
Re: Open declaration is not working in feature files [message #1826405 is a reply to message #1826404] Fri, 24 April 2020 12:56 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4088
Registered: July 2009
Senior Member

Cucumber support is not provided by eclipse.org, it's (most likely) implemented by the project at https://github.com/cucumber/cucumber-eclipse , but are you absolutely certain that your gherkin syntax matches with an underlying step definition? The test runs without an error condition, ignoring whether it passes or fails?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Open declaration is not working in feature files [message #1826450 is a reply to message #1826405] Sat, 25 April 2020 02:34 Go to previous messageGo to next message
Doris Li is currently offline Doris LiFriend
Messages: 2
Registered: April 2020
Junior Member
Thank you for your reply.The test runs without any error though could open declaration.
Also tried with cucumber eclipse plugin(initially using Natural)
I did remove Natural before install cucumber eclipse, still no luck.

[Updated on: Sat, 25 April 2020 02:36]

Report message to a moderator

Re: Open declaration is not working in feature files [message #1843017 is a reply to message #1826450] Sun, 11 July 2021 18:34 Go to previous message
vaishali gajjar is currently offline vaishali gajjarFriend
Messages: 1
Registered: July 2021
Junior Member
How you track your feature file any solution you found? Please let me know I am getting same issue
Previous Topic:Tycho + Target Platform + ServiceLoader
Next Topic:Andmore installation failure
Goto Forum:
  


Current Time: Mon Aug 02 13:11:07 GMT 2021

Powered by FUDForum. Page generated in 0.04295 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top