Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » eGIT is throwing NullPointerException
eGIT is throwing NullPointerException [message #1826331] Thu, 23 April 2020 15:32 Go to next message
Hakan Bayindir is currently offline Hakan BayindirFriend
Messages: 11
Registered: January 2017
Location: Ankara, Turkey
Junior Member

Hello all,

I'm experiencing a strange problem with the latest Eclipse (2020.03) CDT with eGIT. Whenever I open Git perspective, I'm greeted with NullPointerException errors.

The errors popup in every action I do. eGIT's functionality seems unaffected but, errors make it unusable. When I close the perspective completely, errors go away.

The logs don't provide much information, so I cannot dig further. The system is Debian Testing with OpenJDK 14. System was running previous versions (up to 2019.12) so I'm sure that the system has no software dependency problems.

Other parts of the Eclipse is perfectly operational.

Any help will be greatly appreciated.
Re: eGIT is throwing NullPointerException [message #1826336 is a reply to message #1826331] Thu, 23 April 2020 16:56 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31370
Registered: July 2009
Senior Member
Try the EGit forum:

https://www.eclipse.org/forums/index.php/f/48/

Please use the Error Log view to include the stack trace.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: eGIT is throwing NullPointerException [message #1826345 is a reply to message #1826336] Thu, 23 April 2020 18:28 Go to previous messageGo to next message
Hakan Bayindir is currently offline Hakan BayindirFriend
Messages: 11
Registered: January 2017
Location: Ankara, Turkey
Junior Member

Hi Ed,

Thanks for point the right direction, I'll do it now.

Thanks again,

Regards,

Hakan
Re: eGIT is throwing NullPointerException [message #1826439 is a reply to message #1826345] Fri, 24 April 2020 20:38 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 264
Registered: August 2016
Senior Member
This is a known bug in EGit 5.7.0.

Work-arounds are:

  1. Install EGit nightly, which contains a fix for this, from the update site https://download.eclipse.org/egit/updates-nightly , or
  2. Switch on the preference at Preferences->General->Appearance->Use mixed fonts and colors for labels.

Re: eGIT is throwing NullPointerException [message #1826440 is a reply to message #1826439] Fri, 24 April 2020 21:12 Go to previous message
Hakan Bayindir is currently offline Hakan BayindirFriend
Messages: 11
Registered: January 2017
Location: Ankara, Turkey
Junior Member

Hi Thomas,

Thanks for your answer. I've enabled Use mixed fonts and colors for labels option from the settings and, everything is fine now.

All the best,

Hakan
Previous Topic:Unable to Install Eclipse on MAC
Next Topic:Someone Please help!
Goto Forum:
  


Current Time: Thu Aug 13 18:18:16 GMT 2020

Powered by FUDForum. Page generated in 0.02931 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top