Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Eclipse Foundation » Docker Container Support in CDT(Launching Nodejs)
Docker Container Support in CDT [message #1824339] Tue, 14 April 2020 06:52 Go to next message
dev mapluz is currently offline dev mapluzFriend
Messages: 3
Registered: February 2019
Junior Member
hi
i have installed the Docker Tooling in Eclipse 2020-03 (4.156.0) on ubuntu 18

is it possible to debug nodejs / vuejs applications in a docker container with eclipse ide

thanks for your information
Re: Docker Container Support in CDT [message #1824348 is a reply to message #1824339] Tue, 14 April 2020 08:39 Go to previous messageGo to next message
Mickael Istria is currently offline Mickael IstriaFriend
Messages: 860
Registered: July 2009
Location: Grenoble, France
Senior Member

Hi,

A Docker container is a remote machine like any other. Whether you star the Docker container with the Eclipse tools, or CLI or whatever is equivalent: you'll need to use a Node js remote debugger to "contact" the running node.js application and debug is with a host/port couple.
Eclipse Wild Web Developer https://github.com/eclipse/wildwebdeveloper/ can do that pretty well.
Video demo linked from https://github.com/eclipse/wildwebdeveloper/blob/master/RELEASE_NOTES.md#easily-define-root-mapping-for-remote-nodejs-debugger shows how to concretely use that.

I know some 3rd party application like Red Hat Code Ready Studio or JBoss Tools have some more direct link between container and debugger. However, the layers of "magic" don't necessarily make things easier to understand and manipulate than a remote debuggging.
Re: Docker Container Support in CDT [message #1824371 is a reply to message #1824348] Tue, 14 April 2020 14:02 Go to previous message
dev mapluz is currently offline dev mapluzFriend
Messages: 3
Registered: February 2019
Junior Member
hi,
thanks a lot for all these informations; i will watch this
Previous Topic:Download page for win64 - SHA-256 is blank
Next Topic:Eclipse 4.4 and 4.10 on macOS Catalina
Goto Forum:
  


Current Time: Tue Jan 25 20:51:21 GMT 2022

Powered by FUDForum. Page generated in 0.01491 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top