Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Help needed importing Jersey libraries(Jersey)
Help needed importing Jersey libraries [message #1824006] Mon, 06 April 2020 12:48 Go to next message
Aditya B is currently offline Aditya BFriend
Messages: 13
Registered: April 2020
Junior Member
I'm a newcomer to the field of REST services and I was going through tutorials online.
Most of the tutorials are pre-2017, and in most of them the Jersey libraries are downloaded as zip files and then copy-pasted into the lib folder of an existing Eclipse web project.

However, the Jersey downloads are now moved to github and none of the releases have any jar files in them. I'm clueless as to how to import the libraries into my Eclipse project. Any help will be greatly appreciated!
Re: Help needed importing Jersey libraries [message #1824045 is a reply to message #1824006] Tue, 07 April 2020 03:25 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3912
Registered: July 2009
Senior Member

Where on github? It's possible that they're handling dependencies in a different way, now.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Help needed importing Jersey libraries [message #1824224 is a reply to message #1824045] Fri, 10 April 2020 08:11 Go to previous message
Aditya B is currently offline Aditya BFriend
Messages: 13
Registered: April 2020
Junior Member
So they've indeed changed a few things. Maven projects are much better supported now. But for other projects, they've included a link that reads "How to download". Within that link there's an old style bundle that I need to download for the libraries.

I have no idea why they had to complicate a very simple thing, but thankfully the libraries are still available for download.
Previous Topic:How to upload files to a server?
Next Topic:Can't install eclipse
Goto Forum:
  


Current Time: Sat Dec 05 12:51:09 GMT 2020

Powered by FUDForum. Page generated in 0.03169 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top