Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » EGit now forcing GSSAPI-WITH-MIC?
EGit now forcing GSSAPI-WITH-MIC? [message #1823130] Thu, 19 March 2020 21:15 Go to next message
Stephen Marek is currently offline Stephen MarekFriend
Messages: 1
Registered: March 2020
Junior Member
I can't figure out what happened. All I can tell is that I allowed Eclipse to auto update a bunch of components and now it can't connect to any of my repos.

My repos are currently on a LAN server, connection was via SSH. I didn't change any settings on either the server or in Eclipse, and then all the sudden I can no no longer push or pull. I get errors like

Can't connect to any repository: xxxxx (not found)

or

Transport Error: Cannot get remote repository refs. xxxx not found.


I can't tell which version of egit I have, as the Eclipse Marketplace says 5.6.1 but I swear it just updated to 5.8. I also can't seem to get it to let me downgrade, as it keeps choking on

Watching the sshd log, I get

userauth-request for user xxxxx service ssh-connection method gssapi-with-mic

It appears that it keeps trying to log in using gssapi-with-mic even though I unticked it AND moved it to the bottom of the list in Preferences -> General -> Network Connections -> SSH2 -> Authentication Methods

What gives? Why does egit keep insisting on using GSSAPI??? I'm trying to use public key (and I can't get password to work either), and I have no problem logging in via ssh using pubkey via my ssh client.


Any thoughts?
Re: EGit now forcing GSSAPI-WITH-MIC? [message #1823461 is a reply to message #1823130] Thu, 26 March 2020 21:51 Go to previous message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 365
Registered: August 2016
Senior Member
EGit 5.8.0 would be EGit nightly. Do you have https://download.eclipse.org/egit/updates-nightly/ in the update sites configured in your Eclipse? That might explain why it updated to that version.

However, I have this version installed in my Eclipse, too, and I don't see the problems you described. The preferences you mention are honored in my Eclipse.

EGit would use GSSAPI if the server replied initially that it supported it *and* if you had not unchecked it.

However: do check your ~/.ssh/config: does that set PreferredAuthentications? If so, that overrides the Eclipse preference settings.

When the GSSAPI authentication is not successful, the next method tried should usually be "publickey", and the connection should work. Unless your ~/.ssh/config does set PreferredAuthentications and it doesn't include "publickey" (or the server didn't adevrtise this authentication method).

To downgrade if reverting to a previous installation state doesn't work, you could uninstall EGit 5.8.0 and re-install EGit 5.6.1 or 5.7.0.

Also, which Eclipse version are you using?

[Updated on: Thu, 26 March 2020 21:53]

Report message to a moderator

Previous Topic:EGit ignores my attempt to stage files in one repository
Next Topic:Cannot lock due to index.lock not removed after crash
Goto Forum:
  


Current Time: Wed Jun 16 11:22:28 GMT 2021

Powered by FUDForum. Page generated in 0.02205 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top