Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot Find Companion Shared Library(Error message when Opening an Existing Project)
Cannot Find Companion Shared Library [message #1823033] Wed, 18 March 2020 13:11 Go to next message
Keith Stramler is currently offline Keith StramlerFriend
Messages: 12
Registered: November 2015
Junior Member
Hello. I hope all are safe and healthy.

I am a new user to Eclipse. I am having a problem on getting things working properly. I installed Neon (4.6), per my manager, and I get the application to start up and run. However, whenever I try to open an existing project, a BIRT Report, I get the following message.

The Eclipse executable launcher was unable to locate its companion shared library.

I have searched the forum and googled, and found some related posts, but they are more for getting Eclipse to start up and run in the first place. I do not find anything where it specifically talks about trying to open an existing project. I have tried removing the

-startup
plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar

from the Eclipse.ini file and that did not work. I also have gone to the Plugins folder and launched Eclipse from the

org.eclipse.equinox.launcher_1.3.201.v20161025-1711

file. Eclipse launches fine and runs using this file, but I still get the same error message whenever I try to open a project.

I would appreciate any help on trying to resolve this issue. I installed Neon Eclipse IDE for Eclipse Committers, 64-bit, and am using Java version jre1.8.0_211, and using Windows 10. If more information is needed, please let me know.

Thanks for any help.
Re: Cannot Find Companion Shared Library [message #1823066 is a reply to message #1823033] Thu, 19 March 2020 06:17 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31366
Registered: July 2009
Senior Member
So your IDE launches fine but "applications" launched from that IDE don't start. I don't know enough about BIRT to know what it does when you open a BIRT Report project but it appears that it tried to launch something else. Maybe there is a similar issue already in the BIRT-specific forum:

https://www.eclipse.org/forums/index.php/f/2/


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Cannot Find Companion Shared Library [message #1823099 is a reply to message #1823066] Thu, 19 March 2020 13:42 Go to previous message
Keith Stramler is currently offline Keith StramlerFriend
Messages: 12
Registered: November 2015
Junior Member
Thanks, I will search that forum and if I cannot find an answer, I will ask the question there.
Previous Topic:Adding Item into Context Menu using org.eclipse.ui.menus
Next Topic:Upgrading from 2018-12 (4.10.0) to any new release
Goto Forum:
  


Current Time: Thu Aug 13 05:37:38 GMT 2020

Powered by FUDForum. Page generated in 0.02589 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top