Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Filter on Java version >= 11
Filter on Java version >= 11 [message #1823016] Wed, 18 March 2020 07:43 Go to next message
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 46
Registered: March 2020
Member
Hi,

I would like to create an installer with a CompoundTask that downloads and installs JavaFX 11+ SDK. But that task should only be executed if a Java version >= 11 is selected in the installer.
This is needed to create a setup that includes e(fx)clipse and the configuration for JavaFX in cases where Java 11+ is used.

I tried to add this filter: (&(osgi.ee=JavaSE)(version=11))

And I have selected an OpenJDK 11.0.2.

The task was not executed, so I assume the filter did not match.

I have searched for an example on this, but I did not find anything. Can someone please tell me if a filter for a Java version >= 11 is possible and if so, how it should look like?
Re: Filter on Java version >= 11 [message #1823065 is a reply to message #1823016] Thu, 19 March 2020 05:11 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32110
Registered: July 2009
Senior Member
We currently do nothing to set context variables with values based on the selected JRE/JDK. The above filter expression is one generally used like this in an IU's metadata:
    <requiredProperties namespace='osgi.ee' match='(&amp;(osgi.ee=JavaSE)(version=1.8))'/>
and expresses a requirement on an IU that provides this capability. That's not something that could be used as a filter on a setup task.

There is currently no way to express such a filter because there is no variable with a value that could be used for that purpose. We'd need to create something new for that.


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Preference not taking effect?
Next Topic:Unexpected Variable Filter behaviour
Goto Forum:
  


Current Time: Sat Dec 04 05:58:34 GMT 2021

Powered by FUDForum. Page generated in 0.01639 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top