Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » 4DIAC TCP client(Raw TCP client in 4Diac)
4DIAC TCP client [message #1822619] Tue, 10 March 2020 14:29 Go to next message
Paulo Louro is currently offline Paulo LouroFriend
Messages: 31
Registered: February 2020
Member
Hello,

Is it possible to make a raw TCP/IP client on 4DIAC?

I have tryed raw[ip:port] without any success.
Re: 4DIAC TCP client [message #1822620 is a reply to message #1822619] Tue, 10 March 2020 14:32 Go to previous messageGo to next message
Martin Melik-Merkumians is currently offline Martin Melik-MerkumiansFriend
Messages: 96
Registered: March 2016
Member
Hi,

raw is an encoding layer, not a transport layer.
You can send raw strings via raw[].ip[<ip:port>]

Best regards,
Martin
Re: 4DIAC TCP client [message #1822623 is a reply to message #1822620] Tue, 10 March 2020 14:41 Go to previous messageGo to next message
Paulo Louro is currently offline Paulo LouroFriend
Messages: 31
Registered: February 2020
Member
Hi Martin

Thanks, I have been searching for this info, even looked into the FORTE source code but didnt manage to find the answer.

Just tested it an it worked perfect.

Best regards,
Paulo
Re: 4DIAC TCP client [message #1822624 is a reply to message #1822623] Tue, 10 March 2020 14:58 Go to previous messageGo to next message
Paulo Louro is currently offline Paulo LouroFriend
Messages: 31
Registered: February 2020
Member
Hey again

Now that i can send, i'm trying to receive a string. How can this be done?

I have connected a STRING2STRING to the CNF.->REQ and RD_1-> IN but in the Client_1 output says ND.

If i send from the server it increments the events in the CNF of CLIENT_1.

Best regards.
Re: 4DIAC TCP client [message #1822625 is a reply to message #1822624] Tue, 10 March 2020 15:01 Go to previous messageGo to next message
Martin Melik-Merkumians is currently offline Martin Melik-MerkumiansFriend
Messages: 96
Registered: March 2016
Member
Can you send a screenshot of your application?
Re: 4DIAC TCP client [message #1822626 is a reply to message #1822625] Tue, 10 March 2020 15:04 Go to previous messageGo to next message
Paulo Louro is currently offline Paulo LouroFriend
Messages: 31
Registered: February 2020
Member
Hey

There you go.
  • Attachment: Untitled.png
    (Size: 84.47KB, Downloaded 22 times)
Re: 4DIAC TCP client [message #1822628 is a reply to message #1822626] Tue, 10 March 2020 15:13 Go to previous messageGo to next message
Paulo Louro is currently offline Paulo LouroFriend
Messages: 31
Registered: February 2020
Member
Ok I double clicked on the output of CLIENT_1 and deleted the ND, after that I'm able to see the 123 I'm sending via the socket.

Correction i wrote STRING# while watching the FB

[Updated on: Tue, 10 March 2020 15:17]

Report message to a moderator

Re: 4DIAC TCP client [message #1822629 is a reply to message #1822628] Tue, 10 March 2020 15:14 Go to previous messageGo to next message
Martin Melik-Merkumians is currently offline Martin Melik-MerkumiansFriend
Messages: 96
Registered: March 2016
Member
Ok, so this is solved I guess?
Re: 4DIAC TCP client [message #1822630 is a reply to message #1822629] Tue, 10 March 2020 15:18 Go to previous messageGo to next message
Paulo Louro is currently offline Paulo LouroFriend
Messages: 31
Registered: February 2020
Member
I think this is more like a user error then anything else... I'm a new on 4DIAC or IEC 61499 std.

Anyways now I can see the string on the output of the CLIENT_1 FB but no luck getting that into the STRING2STRING.
Re: 4DIAC TCP client [message #1822632 is a reply to message #1822630] Tue, 10 March 2020 15:20 Go to previous messageGo to next message
Martin Melik-Merkumians is currently offline Martin Melik-MerkumiansFriend
Messages: 96
Registered: March 2016
Member
Thats strange. Perhaps redraw that part of the application and redownload. If you see the STRING in the CLIENT it has been typified, so the STRING2STRING should be connected.
Re: 4DIAC TCP client [message #1822646 is a reply to message #1822632] Tue, 10 March 2020 17:40 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1039
Registered: January 2014
Senior Member
for me it looks like that the STRING2STRING was not deployed to the device. Can you have a look in the deployment console and check if your string2string is shown there.
Re: 4DIAC TCP client [message #1822700 is a reply to message #1822646] Wed, 11 March 2020 15:39 Go to previous messageGo to next message
Paulo Louro is currently offline Paulo LouroFriend
Messages: 31
Registered: February 2020
Member
100% correct, the modules were missing in CMAKE and not compiled into FORTE.

Thanks once more for the fast support.
Re: 4DIAC TCP client [message #1822708 is a reply to message #1822700] Wed, 11 March 2020 17:52 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1039
Registered: January 2014
Senior Member
you are welcome
Previous Topic:Building 4DIAC Forte on macOS with luajit leads to segfault on start
Next Topic:about log level suggestion
Goto Forum:
  


Current Time: Sun Oct 25 08:55:11 GMT 2020

Powered by FUDForum. Page generated in 0.10303 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top