Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Plugin could not be found
Plugin could not be found [message #1822446] Fri, 06 March 2020 13:00 Go to next message
Jannis Egelhof is currently offline Jannis EgelhofFriend
Messages: 2
Registered: March 2020
Junior Member
(I can not add links to external pages yet.)

I need a development environment with a plugin for leJOS EV3.
Just google "lejos ev3 plugin" the first result.

I thought it would be a good idea to start with the oomph profile presented by eclipsesource.com.

Next I wanted to adapt it and add the EV3 plugin. I drag and dropped my profile from .p2 directory into the repository explorer as described here:
(https://www.eclipse.org/forums/index.php/t/959921/)]

(One needs to adapt the plugin version range, as it is setted to 0.0.0)
But it does not find the plugin.

ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: artificial_root 1.0.0.v1583498710787 requires 'org.eclipse.equinox.p2.iu; org.lejos.ev3.ldt.feature.feature.group [0.9.0,1.0.0]' but it could not be found



Re: Plugin could not be found [message #1822548 is a reply to message #1822446] Mon, 09 March 2020 16:50 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32110
Registered: July 2009
Senior Member
Are you saying this this doesn't work?
<?xml version="1.0" encoding="UTF-8"?>
<setup.p2:P2Task
    xmi:version="2.0"
    xmlns:xmi="http://www.omg.org/XMI"
    xmlns:setup.p2="http://www.eclipse.org/oomph/setup/p2/1.0">
  <requirement
      name="org.lejos.ev3.ldt.feature.feature.group"/>
  <repository
      url="http://www.lejos.org/tools/eclipse/plugin/ev3"/>
</setup.p2:P2Task>

We test that listing that it resolves:

https://www.eclipse.org/setups/marketplace/?url=https://marketplace.eclipse.org/content/lejos-ev3-plug

If you need to post "links" add a space around the ":"


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Plugin could not be found [message #1822591 is a reply to message #1822548] Tue, 10 March 2020 10:22 Go to previous message
Jannis Egelhof is currently offline Jannis EgelhofFriend
Messages: 2
Registered: March 2020
Junior Member
Thanks for your time and your answer. I checked the xml file. EV3 was only listed under requirement. There was no entry for repository which makes sense.
So it is solved for me.
Previous Topic:Eclipse will not install
Next Topic:Complete reference for all concepts in Oomph?
Goto Forum:
  


Current Time: Sat Dec 04 04:28:43 GMT 2021

Powered by FUDForum. Page generated in 0.02255 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top