Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Installer Error(Eclipse just won't download, help?)
Eclipse Installer Error [message #1822417] Thu, 05 March 2020 19:43 Go to next message
KCoder . is currently offline KCoder .Friend
Messages: 2
Registered: March 2020
Junior Member
Hello, I was trying to download Eclipse and then it gave me an error. I tried countless methods, none of them worked. Does anyone have any advice?

This is the error I encountered:

ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:549)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:341)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:815)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3827)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3755)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3736)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3629)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.installPerform(SimpleVariablePage.java:1325)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.access$32(SimpleVariablePage.java:1187)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage$20.run(SimpleVariablePage.java:1132)
Re: Eclipse Installer Error [message #1822434 is a reply to message #1822417] Fri, 06 March 2020 05:15 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30993
Registered: July 2009
Senior Member
Probably the full information included the name of the file that it's checking. Perhaps a corrupt file was downloaded and is now in the bundle pool. This page has some details for trying to repair the pool:

https://www.eclipse.org/setups/installer/question/

Specifically these details:

Use the eclipse installer's Bundle Pools... menu item to manage where this pool is physically located on disk; this location can become large. The Bundle Pool Management dialog supports garbage collecting of unused artifacts, i.e., if you delete an installation, the artifacts it uses can potentially be removed from disk. In addition, if some artifact becomes corrupted, or if a corrupted artifact is downloaded from some mirror site, this dialog can be used to detect the damage and to repair it.
Previous Topic:Eclipse Information center as a Web Archive
Next Topic:I have a Color issue
Goto Forum:
  


Current Time: Sun Mar 29 14:50:26 GMT 2020

Powered by FUDForum. Page generated in 0.04334 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top