Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » Is GEF 5.1.0 compatible with efxclipse 3.5.0(Is GEF 5.1.0 compatible with efxclipse 3.5.0)
Is GEF 5.1.0 compatible with efxclipse 3.5.0 [message #1822373] Thu, 05 March 2020 07:54 Go to next message
girijanandan nucha is currently offline girijanandan nuchaFriend
Messages: 25
Registered: January 2019
Location: Bangalore, India
Junior Member
Hi All,

Is GEF 5.1.0 compatible with efxclipse 3.5.0 ?
Re: Is GEF 5.1.0 compatible with efxclipse 3.5.0 [message #1822384 is a reply to message #1822373] Thu, 05 March 2020 12:22 Go to previous message
Matthias Wienand is currently offline Matthias WienandFriend
Messages: 230
Registered: March 2015
Senior Member
Hi Girijanandan,

yes, it should work fine.

GEF depends on JavaFX, which can be provided in an OSGi context by e(fx)clipse.

Where to find JavaFX depends on your Java version. More recent versions of e(fx)clipse are compatible with more recent versions of Java.

When using Java 7 or 8, e(fx)clipse will find the necessary jars in your Java installation.

When using Java 11, you need to set a javafx SDK directory, so that e(fx)clipse can find JavaFX.

Best regards,
Matthias
Previous Topic:Where to get I18N Bundle for GEF 3.11
Next Topic:Selecting a node after creation
Goto Forum:
  


Current Time: Tue Sep 27 00:37:02 GMT 2022

Powered by FUDForum. Page generated in 0.02375 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top