Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse on Win 10 x64 with AdoptOpenJDK jdk-13.0.2+8(Unusably slow for everyone else too?)
Eclipse on Win 10 x64 with AdoptOpenJDK jdk-13.0.2+8 [message #1822364] Wed, 04 March 2020 23:42 Go to next message
Justin Dolezy is currently offline Justin DolezyFriend
Messages: 12
Registered: July 2009
Junior Member
Has anyone tried this combination? I've tried 2019.12 with jdk-13.0.2+8 (x64) but it takes forever to start.

We were actually going to move our RCP app from Java 8 to 13 - the MacOS and Win x86_32 builds are fine, but running both our app and Eclipse on the x64 is shocking - it takes minutes for anything to happen and chews up all CPU.

Wondering if others have seen this or just me?! Not finding anything about this on Bugzilla/Google..

Thanks,
Justin
Re: Eclipse on Win 10 x64 with AdoptOpenJDK jdk-13.0.2+8 [message #1822369 is a reply to message #1822364] Thu, 05 March 2020 06:15 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32071
Registered: July 2009
Senior Member
Perhaps this Bugzilla report is related:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=548443

Note that I just tried jdk-13.0.2+8 on my Windows 7 machine and I see no performance problems with that. It starts up in a way that is not noticeably different than when Java 8 is used.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse on Win 10 x64 with AdoptOpenJDK jdk-13.0.2+8 [message #1822379 is a reply to message #1822369] Thu, 05 March 2020 10:11 Go to previous message
Justin Dolezy is currently offline Justin DolezyFriend
Messages: 12
Registered: July 2009
Junior Member
No, definitely not Windows Defender - I have it disabled, and was watching Task Manager to see if it was kicking in for some reason, so not that. That issue turns a 10 second startup into a minute - but this issue makes it a 10 minute start!

Switching the JRE to the 64bit Java 8 and Java 11 returns things back to normal (~10s) so I'm fairly sure it's not the Windows configuration. Might give the previous Java 13 build a spin out of curiosity.

Looks like we'll go with 11 though, as having to move off 8 due to inability to notarize our MacOS build for Catalina..
Previous Topic:Eclipse 2018-09 and Amazon Corretto
Next Topic:Is Eclipse 2019-06 meant to work with Java 9+?
Goto Forum:
  


Current Time: Wed Oct 20 21:13:35 GMT 2021

Powered by FUDForum. Page generated in 0.01675 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top