Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1( Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))")
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1 [message #1822246] Mon, 02 March 2020 13:26 Go to next message
Veerababu  Maragani is currently offline Veerababu MaraganiFriend
Messages: 21
Registered: June 2019
Junior Member
Hi ,

I am getting the below exception in console, how to resolve this exception.
Can anyone guide me.


ENTRY com.spacetimeinsight.sistudio.help 4 0 2020-03-02 18:49:55.844
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.spacetimeinsight.sistudio.help [281]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"

at org.eclipse.osgi.container.Module.start(Module.java:462)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1844)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1837)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1778)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1742)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1664)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)
Re: Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(versi [message #1822256 is a reply to message #1822246] Mon, 02 March 2020 15:54 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31640
Registered: July 2009
Senior Member
It looks like you're running something that requires Java 11 in a Java runtime that is less than Java 11.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(versi [message #1822279 is a reply to message #1822256] Tue, 03 March 2020 07:17 Go to previous message
Veerababu  Maragani is currently offline Veerababu MaraganiFriend
Messages: 21
Registered: June 2019
Junior Member
Can anybody provide sample created example for the eclipse information center as a Web Archive

i followed the steps which has given in the below url but cant able to do that and getting the below exception

HTTP Status 404 Not Found
Type Status Report

Message BridgeServlet: /help/

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Apache Tomcat/9.0.26

https://help.eclipse.org/2019-12/index.jsp?topic=%2Forg.eclipse.platform.doc.isv%2Fguide%2Fua_help_war.htm

[Updated on: Tue, 03 March 2020 07:20]

Report message to a moderator

Previous Topic:Multiple makefile errrors
Next Topic:Eclipse Information center as a Web Archive
Goto Forum:
  


Current Time: Sat Dec 05 09:35:40 GMT 2020

Powered by FUDForum. Page generated in 0.03558 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top