Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » java.lang.UnsatisfiedLinkError when starting up eclipse-jee-2019-12 on Linux(Fail to install the latest Eclipse for Java EE while older version Oxygen works)
java.lang.UnsatisfiedLinkError when starting up eclipse-jee-2019-12 on Linux [message #1822086] Thu, 27 February 2020 04:17 Go to next message
Walter Newcastle is currently offline Walter NewcastleFriend
Messages: 2
Registered: February 2020
Junior Member
On CentOS/RHEL 6 I successfully can run the Oxygen IDE (extracted from eclipse-jee-oxygen-R-linux-gtk-x86_64.tar.gz).

However I now wanted to upgrade to the latest version 4.14 /2019-12. After extracting eclipse-jee-2019-12-R-linux-gtk-x86_64.tar.gz I tried to run the eclipse executable, but I get on the command line the error "An error has occurred. See the log file".

The log file then shows:

!SESSION 2020-02-27 12:39:29.130 -----------------------------------------------
eclipse.buildId=4.14.0.I20191210-0610
java.version=1.8.0_222
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.jee.product

!ENTRY org.eclipse.osgi 4 0 2020-02-27 12:39:34.004
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: org.eclipse.swt.internal.gtk.OS._cachejvmptr()V
	at org.eclipse.swt.internal.gtk.OS._cachejvmptr(Native Method)
	at org.eclipse.swt.internal.gtk.OS.cachejvmptr(OS.java:495)
	at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:93)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:209)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:155)
	at org.eclipse.swt.widgets.Display.<clinit>(Display.java:164)
	at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:762)
	at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:166)
	at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:180)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1438)


What's going wrong? Is it possible to run version 4.14 /2019-12 on CentOS 6?

Please note: I need to do an offline install, therefore I used the .tar.gz archive. Also, I cannot upgrade the OS to a more recent version.
Re: java.lang.UnsatisfiedLinkError when starting up eclipse-jee-2019-12 on Linux [message #1822088 is a reply to message #1822086] Thu, 27 February 2020 05:24 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30993
Registered: July 2009
Senior Member
Older versions of Eclipse worked with GTK 2 and GTK 3. The newer versions only support GTK 3 so you'll minimally need to update to a newer GTK 3 version because apparently the GTK version you have does have libraries to satisfy what SWT needs. A great many GTK-specific problems have been fixed in the last years, so the option to continue using an older version of Eclipse is not ideal.
Re: java.lang.UnsatisfiedLinkError when starting up eclipse-jee-2019-12 on Linux [message #1822151 is a reply to message #1822088] Fri, 28 February 2020 03:03 Go to previous messageGo to next message
Walter Newcastle is currently offline Walter NewcastleFriend
Messages: 2
Registered: February 2020
Junior Member
Thanks Ed.

I had a look at installing GTK3 on the CentOS 6 machine, but when searching for gtk3 via yum with the standard repos nothing comes up . - Are there other CentOS 6 repos providing gtk3?
Re: java.lang.UnsatisfiedLinkError when starting up eclipse-jee-2019-12 on Linux [message #1822155 is a reply to message #1822151] Fri, 28 February 2020 07:38 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30993
Registered: July 2009
Senior Member
Sorry, I have little expertise and experience with Linux. I only have a virtual box for that and try to keep it up-to-date with the latest. The last time I complained about an SWT problem that was specific to Linux (GTK), it turned out that I needed to update my OS version because it was deemed too old to be supported.

And I doubt there are many on this forum who can answer your question. Probably Google is your best friend in this case...
Previous Topic:New project not showing pydev
Next Topic:How do i open a jar-file in eclipse to be able to run it?
Goto Forum:
  


Current Time: Sun Mar 29 16:37:03 GMT 2020

Powered by FUDForum. Page generated in 0.12509 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top