Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse update error
Eclipse update error [message #1821866] Fri, 21 February 2020 11:37 Go to next message
Eric Malalel is currently offline Eric MalalelFriend
Messages: 3
Registered: February 2020
Junior Member
I have to replace a developer who left us with no much doc and when I want to update its Eclipse environment I get this error message:

An error occurred while collecting items to be installed session context was:(profile=C__Install Applications_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.epp.mpc.core,1.8.1.v20191107-0507
No repository found containing: osgi.bundle,org.eclipse.epp.mpc.ui,1.8.1.v20191119-1757
No repository found containing: org.eclipse.update.feature,org.eclipse.epp.mpc,1.8.1.v20191119-1757

I am quite new to Eclipse, please advise on how to remove this error.
Re: Eclipse update error [message #1821874 is a reply to message #1821866] Fri, 21 February 2020 14:14 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3624
Registered: July 2009
Senior Member

I don't know the answer, but it sounds related to this email thread: https://www.eclipse.org/lists/cross-project-issues-dev/msg17454.html

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse update error [message #1821893 is a reply to message #1821874] Fri, 21 February 2020 16:30 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30993
Registered: July 2009
Senior Member
It's been suggested that reloading the "mpc" (download.eclipse.org/mpc/updates/releases/...) repository in the Window -> Preferences -> Install/Update -> Available Software Sites might help. Or disabling that site in the preferences.
Re: Eclipse update error [message #1821942 is a reply to message #1821893] Mon, 24 February 2020 08:26 Go to previous message
Ungureanu Stefan is currently offline Ungureanu StefanFriend
Messages: 1
Registered: February 2020
Junior Member
Changing the update site protocol from http to https worked for me. This setting can be found in Window -> Preferences -> Install/Update -> Available Software Sites.

(found the info on github pages, but I'm nou allowed to post external urls...)
Previous Topic:no library path?
Next Topic:Internal server error when generating password for Gerrit
Goto Forum:
  


Current Time: Sun Mar 29 16:20:28 GMT 2020

Powered by FUDForum. Page generated in 0.12524 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top