Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » classpath problems after updating to eclipse 2019-12
classpath problems after updating to eclipse 2019-12 [message #1820965] Mon, 03 February 2020 15:55 Go to next message
Eddie L. is currently offline Eddie L.Friend
Messages: 2
Registered: February 2020
Junior Member
All my projects worked fine in eclipse 2019-03. Today I installed the update my eclipse installation offered me. This update installed 2019-12.
Since then I am not able to run anything because I get either ClassNotFoundExceptions or FileNotFoundExceptions as soon as a resource is accessed (or a class file from my test source directory).
I can't see any problems in .classpath (which is the same as before the update).

Has anything changed in the way how classes and resource files are accessed?
How could I find out what's wrong here?

I am using openJDK 8 and maven.
Re: classpath problems after updating to eclipse 2019-12 [message #1821041 is a reply to message #1820965] Tue, 04 February 2020 17:27 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1828
Registered: July 2009
Senior Member
You might be affected by https://bugs.eclipse.org/558495. To check please open the run configuration and click "Show Command Line". Check if the -classpath is quoted or if a text file is referenced containing the classpath - with quotes?

The problem has been fixed in 2020-03 M1, please update Eclipse. In the bug report you will even find a link to an update site that patches JDT just with the fix for this bug.

[Updated on: Tue, 04 February 2020 17:28]

Report message to a moderator

Re: classpath problems after updating to eclipse 2019-12 [message #1821101 is a reply to message #1821041] Wed, 05 February 2020 16:03 Go to previous message
Eddie L. is currently offline Eddie L.Friend
Messages: 2
Registered: February 2020
Junior Member
This was indeed my problem. After updating the classes and resources are found.

Thanks a lot,
Eddie
Previous Topic:Error fixing window takes a long time to open and other responsiveness problems
Next Topic:How To "Turn Off" A Plugin And Project Using The "Module Path"?
Goto Forum:
  


Current Time: Thu Oct 29 11:48:32 GMT 2020

Powered by FUDForum. Page generated in 0.02237 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top