Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » MoDisco » MoDisco 1.5.1M2 amputations - UML2 and BIRT
MoDisco 1.5.1M2 amputations - UML2 and BIRT [message #1819435] Wed, 15 January 2020 11:09
Ed Willink is currently offline Ed WillinkFriend
Messages: 6589
Registered: July 2009
Senior Member
Hi

It has become clear [1] that the MoDisco support for UML has been catastrophically broken since at least 2013, and probably since 2012 when UML2 4.0 changed the nsURI for the addition of UML 2.4 support.

In the absence of community support to rework the ATL transformations that have obsolete metamodel references, there is no point retaining functionality that can only waste user's time. UML2 support will therefore be amputated in three weeks time for 1.5.1M2. If you want to step up to retain UML2, please add a comment to [1].

It has also become clear [2] that the BIRT project is dead. BIRT was mostly removed from Eclipse 2019-12 leaving just the chartmodel plugins upon which MoDisco and others depend.

Since 1.5.1M2 will have a significant reduction in dead functionality wrt UML2, amputating BIRT will also happen in 3 weeks time unless a comment on [2] makes the case for retention.

Regards

Ed Willink

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=559115
[2] https://bugs.eclipse.org/bugs/show_bug.cgi?id=557989
Previous Topic:On the immediate future of the MoDisco project
Next Topic:Converting Java to KDM for analysis
Goto Forum:
  


Current Time: Sat Feb 22 07:51:05 GMT 2020

Powered by FUDForum. Page generated in 0.01831 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top