Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GlassFish » Problem Client Swing Java Web Start (grizzly-npn-bootstrap.jar not found )
Problem Client Swing Java Web Start [message #1819044] Mon, 06 January 2020 08:34
CLOS jerome is currently offline CLOS jeromeFriend
Messages: 3
Registered: January 2020
Junior Member
Hello,

I'm a French developer and, as my English is not very good, I'm using an automatic translator to write this message. By need and curiosity, I want to make a J2EE8 application using the GlassFish 5.1 application server. This is my first J2EE application.

To summarise, the problem I encounter is the execution of my client application via Java Web Start. On the client workstation, the application seems to download correctly, but when I run it I have the following exception in Java Web Start :

com.sun.deploy.net.FailedDownloadException: Impossible de charger la ressource : http://jerome:8080/___JWSappclient/___system/s1as/glassfish/modules/endorsed/grizzly-npn-bootstrap.jar
at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
at com.sun.deploy.net.DownloadEngine.downloadResource(Unknown Source)
at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
at com.sun.javaws.LaunchDownload$DownloadTask.call(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

On the server side, I have several identical exceptions of the following type:

java.lang.NullPointerException
at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:149)
at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:182)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:156)
at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:218)
at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:95)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:260)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:177)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:109)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:88)
at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:53)
at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:515)
at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:89)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:94)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:33)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:114)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:569)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:549)
at java.lang.Thread.run(Thread.java:748)

My development environment is as follows:
Windows version 10 professional 64 bits
GlassFish 5.1
Eclipse 2019 12
JDK1.8.0_191 or JDK1.8.0_231 => I tried both versions of JDK.
GlassFish Tools Plugin 1.0 or 1.01 => I tried both versions.

History :
At the beginning, I tried to create the JNLP file myself, but I didn't know where to put it on the server side. I later found out that GlassFish would generate a JNLP file and sign the jar files as well.My client project is a swing project. My client project is a swing project. My client project is a client project, but I couldn't resolve the error so I went back to a new server with a new EAP project. Within this project I created only one client project, and this client project has only one Main class with a Main function that does nothing. With this minimalist project, the error is exactly the same as with my original project which was more important (swing client plus EJB project).

I searched the Internet for several days, but I couldn't find a solution. I hope that someone will be able to help me to solve this problem, because I can't run a client application on remote computers via Java Web Start. I thank in advance of the person(s) who will be able to help me.

Yours sincerely,
Previous Topic:MDB takes exactly 2 minutes to read JMS message
Next Topic:Glassfish news
Goto Forum:
  


Current Time: Tue Mar 31 03:25:20 GMT 2020

Powered by FUDForum. Page generated in 0.02015 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top