Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Installer for ubuntu?(installl)
Installer for ubuntu? [message #1818958] Fri, 03 January 2020 13:53 Go to next message
Isli Bruns is currently offline Isli BrunsFriend
Messages: 4
Registered: January 2020
Junior Member
Hi,

I tried to use the installer of Eclipse IDE 2019‑12 64bit with
Linux 4.15.0-72-lowlatency #81-Ubuntu SMP PREEMPT Tue Nov 26 13:09:12 UTC 2019 i686 i686 i686 GNU/Linux

execution fails: bash: ./eclipse-inst: Cannot execute the binary: Error in program file format
(bash: ./eclipse-inst: Kann die Binärdatei nicht ausführen: Fehler im Format der Programmdatei).

Is there another dist of a binary?

many regards and an happy new year,
Isli

Re: Installer for ubuntu? [message #1818981 is a reply to message #1818958] Sat, 04 January 2020 06:56 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30820
Registered: July 2009
Senior Member
You can always download a package from https://www.eclipse.org/downloads/packages/ but if the "eclipse-inst" executable doesn't run on your Linux variant ,it's likely that the "eclipse" executable in the package won't run for exactly the same reason.
Re: Installer for ubuntu? [message #1818997 is a reply to message #1818981] Sat, 04 January 2020 11:23 Go to previous messageGo to next message
Isli Bruns is currently offline Isli BrunsFriend
Messages: 4
Registered: January 2020
Junior Member
Hi,

thanks for your answer. Sounds not good. Ubuntu seems to be exotic.

Next, I'll try the complicated procedure as mentioned in https://itsfoss.com/install-latest-eclipse-ubuntu/.
Re: Installer for ubuntu? [message #1818999 is a reply to message #1818997] Sat, 04 January 2020 12:42 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30820
Registered: July 2009
Senior Member
But I posted this on the wrong thread:

BTW, I assume you downloaded https://www.eclipse.org/downloads/download.php?file=/oomph/epp/2019-12/R/eclipse-inst-linux64.tar.gz and that works for me on Ubuntu...

So Ubuntu is not exotic and this worked for me on the 16.x and now the 19.0 versions.
Re: Installer for ubuntu? [message #1819000 is a reply to message #1818997] Sat, 04 January 2020 13:22 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 525
Registered: August 2014
Senior Member
Before continuing, make sure that your Ubuntu is 64 bits (and not 32 bits).


--

Tauno Voipio
Re: Installer for ubuntu? [message #1819003 is a reply to message #1818997] Sat, 04 January 2020 13:57 Go to previous messageGo to next message
Isli Bruns is currently offline Isli BrunsFriend
Messages: 4
Registered: January 2020
Junior Member
Frustrated, so many hours and things did not work.

You're right:
bash: ./eclipse: Kann die Binärdatei nicht ausführen: Fehler im Format der Programmdatei

file ./eclipse
./eclipse: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib, for GNU/Linux 2.6.32, BuildID[sha1]=b621fbc20e80d7ac375ece11a5775fc6686b71c7, with debug_info, not stripped

Let's do some analysis:

Check Ubuntu Version:
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

Check installed Java version:
$ java -version
openjdk version "1.8.0_232"
OpenJDK Runtime Environment (build 1.8.0_232-8u232-b09-0ubuntu1~18.04.1-b09)
OpenJDK Server VM (build 25.232-b09, mixed mode)

Check GTK-Version:
~$ dpkg -s libgtk-3-0|grep '^Version'
Version: 3.22.30-1ubuntu4

Run eclipse (loaded from umake)
./eclipse
bash: ./eclipse: Kann die Binärdatei nicht ausführen: Fehler im Format der Programmdatei

Check that binary:
~/.local/share/umake/ide/eclipse$ file ./eclipse
./eclipse: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib, for GNU/Linux 2.6.32, BuildID[sha1]=b621fbc20e80d7ac375ece11a5775fc6686b71c7, with debug_info, not stripped

Running eclipse (loadfed from snapcraft -> Photon June 2018)
many errors within GTK, empty editor, stopping program fails
e.q.

(Eclipse:6549): GLib-CRITICAL **: 13:35:16.622: g_base64_encode_step: assertion 'in != NULL' failed
java.lang.NoSuchMethodError: atkObject_get_role
at org.eclipse.swt.internal.gtk.OS._g_main_context_iteration(Native Method)
at org.eclipse.swt.internal.gtk.OS.g_main_context_iteration(OS.java:1626)
...
(Eclipse:6549): Gtk-WARNING **: 13:35:44.177: Theme parsing error: gtk.css:4549:12: not a number
(Eclipse:6549): Gtk-WARNING **: 13:35:44.177: Theme parsing error: gtk.css:4549:12: Expected a string.
(WebKitWebProcess:6646): GLib-CRITICAL **: 13:35:44.252: g_variant_get_type: assertion 'value != NULL' failed
(WebKitWebProcess:6646): GLib-CRITICAL **: 13:35:44.252: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed
(WebKitWebProcess:6646): GLib-CRITICAL **: 13:35:44.252: g_variant_get_int32: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_INT32)' failed

(Eclipse:6549): Gtk-CRITICAL **: 13:35:46.818: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
killed



Now, I have no plan, what to do. Any hints, please?

Thx, Isli
Re: Installer for ubuntu? [message #1819007 is a reply to message #1819000] Sat, 04 January 2020 14:54 Go to previous messageGo to next message
Ralph Abadie is currently offline Ralph AbadieFriend
Messages: 1
Registered: January 2020
Junior Member
Everything works for me even on the 32-bit version, strange.
Re: Installer for ubuntu? [message #1819014 is a reply to message #1819003] Sat, 04 January 2020 19:20 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 525
Registered: August 2014
Senior Member
It seems that you have to upgrade to 64 bit Ubuntu.

If I were you, I'd back up the user directories, take a copy of repository selections with APT (see Debian APT documentation or google for it) and jettison the Linux, then install a 64 bit Ubuntu from afresh (never needed to try it myself).

Google found quite many good responses with 'change 32 bit Ubuntu to 64 bit'.

After having a working 64 bit system, get the Eclipse Linux installer and use it to install your flavor of Eclipse. IIRC, the Ubuntu installation sets up a Java installation which is OK for Eclipse, at least in my 18.04LTS, 19.04 and 19.10 Ubuntus.


--

Tauno Voipio
Re: Installer for ubuntu? [message #1819034 is a reply to message #1819014] Sun, 05 January 2020 22:09 Go to previous message
Isli Bruns is currently offline Isli BrunsFriend
Messages: 4
Registered: January 2020
Junior Member
Tauno Voipio wrote on Sat, 04 January 2020 19:20
It seems that you have to upgrade to 64 bit Ubuntu.

If I were you, I'd back up the user directories, take a copy of repository selections with APT (see Debian APT documentation or google for it) and jettison the Linux, then install a 64 bit Ubuntu from afresh (never needed to try it myself).

Google found quite many good responses with 'change 32 bit Ubuntu to 64 bit'.

After having a working 64 bit system, get the Eclipse Linux installer and use it to install your flavor of Eclipse. IIRC, the Ubuntu installation sets up a Java installation which is OK for Eclipse, at least in my 18.04LTS, 19.04 and 19.10 Ubuntus.


So I did and it works! Eclipse now is runing stable.

But it was an odyssey because of some other problems in the context ( UEFI boot versus legacy with password protected BIOS, 1st update ubuntu got stuck at systemd and kill the update also killed disk consistency, user homes could not be restored completely, just a few other problems ...)

But, eclipse now runs with 64 ubuntu.

Many thanks again!
Previous Topic:Network blocked by a proxy
Next Topic:can't install eclipse if mse(antivirus) is on
Goto Forum:
  


Current Time: Mon Jan 27 10:37:25 GMT 2020

Powered by FUDForum. Page generated in 0.03392 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top