Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » Subscrible on raspberry
Subscrible on raspberry [message #1818716] Tue, 24 December 2019 13:27 Go to next message
joy woo is currently online joy wooFriend
Messages: 79
Registered: May 2019
Member
when i run forte with a simple FB subscribe
it throw an error:

INFO: T#1366997896321863: CBSDSocketInterface: Opening UDP receiving connection at: 192.168.10.171:61500
INFO: T#1366997896321863: Connection closed by peer
WARNING: T#2465796559782561: CBSDSocketInterface: setsockopt(IP_ADD_MEMBERSHIP) failed: Invalid argument
ERROR: T#2465796559782561: CModbusComLayer:: Invalid input parameters
INFO: T#2465796559782561: CModbusLayer::closeConnection()
DEBUG: T#7154079781972633: CSocketBaseLayer::closeConnection()
Re: Subscrible on raspberry [message #1818717 is a reply to message #1818716] Tue, 24 December 2019 13:36 Go to previous messageGo to next message
joy woo is currently online joy wooFriend
Messages: 79
Registered: May 2019
Member
sorry, i see the error came from modbus, i will check the parameters if were correct.
Re: Subscrible on raspberry [message #1818718 is a reply to message #1818717] Tue, 24 December 2019 13:38 Go to previous messageGo to next message
joy woo is currently online joy wooFriend
Messages: 79
Registered: May 2019
Member
beacuse i don't have the new modbus documentation & ftbs, i can only use the old modbus
Re: Subscrible on raspberry [message #1818739 is a reply to message #1818718] Thu, 26 December 2019 10:12 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 932
Registered: January 2014
Senior Member
The modbus situation for 4diac is currently rather bad. We don't have any modbus devices for testing and also not the need. Anybody who want to step in to improve the situation is warmly welcome. However the starting point should be the patches from Martin Jobst.
Previous Topic:Raspberry forte 's debugging problem
Next Topic:HMI question
Goto Forum:
  


Current Time: Mon Jan 27 10:40:21 GMT 2020

Powered by FUDForum. Page generated in 0.04102 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top