Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Eclipse exported Product file is not working.( Product is created for the eclipse plug-in developed on Ecore model. )
Eclipse exported Product file is not working. [message #1817710] Thu, 28 November 2019 06:54 Go to next message
Snehal Nakave is currently offline Snehal NakaveFriend
Messages: 9
Registered: September 2018
Junior Member
Hi Team,

I am working on Eclipse project where Ecore model is defined. On the model, I have developed a database plugin (eclipse plug-in project) where I am reading data from database (plugin functionality). For reading, a button on menu is added and on click of button in runtime eclipse, event to read happens. The plugin works when run as eclipse application.

I have created a product of this application. (windows and linux both) using export wizard. When I run product file (.exe) for the first time, on console I get "framework event error in eclipse" but product file is opened. When I try to click the button (database read, plugin functionality) in the .exe, it gives error as "org.eclipse.core.runtime.CoreException: plug-in was unable to load class" and "the proxied handler for could not be loaded "

I have added all required plug-ins in the product configuration.
What should be the issue? The button click event is not recognised and handled.
Re: Eclipse exported Product file is not working. [message #1817719 is a reply to message #1817710] Thu, 28 November 2019 09:08 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 179
Registered: April 2012
Senior Member
Did you add the recommended plug-in start levels in the 'configuration' tab of the product definition file?

Which version of eclipse are you using? Please provide stack-traces of the errors, from these short descriptions it is very hard to guess what is going on.
Re: Eclipse exported Product file is not working. [message #1817725 is a reply to message #1817719] Thu, 28 November 2019 09:27 Go to previous messageGo to next message
Snehal Nakave is currently offline Snehal NakaveFriend
Messages: 9
Registered: September 2018
Junior Member
Eclipse version 2019-06 is being used. Earlier we were working on Eclipse Photon but while creating product, Antlr version issue was coming as it was expecting Antlr version 4.3 and Xtext need Antlr version 3.2. Eclipse had both but as a plugin content only one version was accepted. So changed to latest Eclipse version.

I have attached the documents having stack-trace of errors, product configuration and plugin details.

Thanks,
Snehal
Re: Eclipse exported Product file is not working. [message #1817727 is a reply to message #1817725] Thu, 28 November 2019 09:33 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 179
Registered: April 2012
Senior Member
The demo.handlers.ReplicationHandler class cannot be found by the class loader. Does org.abc.xyz.database have a dependency on the plug-in that provides that class? Does the packaged jar of the plug-in that provides the class contain the class (open the jar with zip)?
Re: Eclipse exported Product file is not working. [message #1817728 is a reply to message #1817727] Thu, 28 November 2019 09:43 Go to previous messageGo to next message
Snehal Nakave is currently offline Snehal NakaveFriend
Messages: 9
Registered: September 2018
Junior Member
The project org.abc.xyz.database itself is the plugin developed. The demo.handlers.ReplicationHandler class is in that project only. For creating product, a separate product package is created.

The packaged jar of org.abc.xyz.database in the created product, has the ReplicationHandler class.
I have attached the package structure of the project.

[Updated on: Thu, 28 November 2019 10:37]

Report message to a moderator

Re: Eclipse exported Product file is not working. [message #1817743 is a reply to message #1817728] Thu, 28 November 2019 12:48 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 179
Registered: April 2012
Senior Member
Is the demo.handlers package exported in the manifest (runtime tab)?
Re: Eclipse exported Product file is not working. [message #1817744 is a reply to message #1817743] Thu, 28 November 2019 12:57 Go to previous messageGo to next message
Snehal Nakave is currently offline Snehal NakaveFriend
Messages: 9
Registered: September 2018
Junior Member
Yes It is added. Check the attached image. index.php/fa/36857/0/
Re: Eclipse exported Product file is not working. [message #1817756 is a reply to message #1817744] Thu, 28 November 2019 14:39 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 876
Registered: January 2012
Senior Member

Can you check that your .class file is actually in the jar?

Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: Eclipse exported Product file is not working. [message #1817781 is a reply to message #1817756] Fri, 29 November 2019 04:48 Go to previous messageGo to next message
Kirti Mahajan is currently offline Kirti MahajanFriend
Messages: 11
Registered: October 2019
Junior Member
Yes, I have .xtend file and it is already present in the jar file. I have attached screenshot also.

[Updated on: Fri, 29 November 2019 05:27]

Report message to a moderator

Re: Eclipse exported Product file is not working. [message #1817785 is a reply to message #1817781] Fri, 29 November 2019 06:25 Go to previous messageGo to next message
Kirti Mahajan is currently offline Kirti MahajanFriend
Messages: 11
Registered: October 2019
Junior Member
Hi Brian ,

Just realized, the .class files are not generated for the database plugin. There are compilation errors while doing the Export product. It says "Compilation errors occurred during the operation. A zip file containing the build logs has been generated and placed at G:\Config-Tool"

index.php/fa/36867/0/

How to remove the compilation error?
  • Attachment: Capture.JPG
    (Size: 16.49KB, Downloaded 156 times)
Re: Eclipse exported Product file is not working. [message #1817808 is a reply to message #1817785] Fri, 29 November 2019 12:08 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 876
Registered: January 2012
Senior Member

Hi Kirti.

My recommendation is to use Maven/Tycho for your builds. The Export wizard is very slow and is also very hard to diagnose when things go wrong. And it's also very slow compared to Maven/Tycho.

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: Eclipse exported Product file is not working. [message #1817810 is a reply to message #1817785] Fri, 29 November 2019 13:10 Go to previous messageGo to next message
Kirti Mahajan is currently offline Kirti MahajanFriend
Messages: 11
Registered: October 2019
Junior Member
Thanks.

It is resolved Now. I missed .classpath and .project files to adding in Build tab. In database plugin already generated .classpath file. But not added to build tab because of that at the time of exporting product package folder database jar file have not created .class files.

index.php/fa/36876/0/
  • Attachment: buildtab.JPG
    (Size: 56.12KB, Downloaded 140 times)

[Updated on: Fri, 29 November 2019 13:12]

Report message to a moderator

Re: Eclipse exported Product file is not working. [message #1817811 is a reply to message #1817810] Fri, 29 November 2019 13:22 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 179
Registered: April 2012
Senior Member
It is odd that you have to include the .classpath and .project file as build targets.
- I have seen what you have warnings on your build.properties file, you should have checked them. Probably you missed including xtend-gen as source folder. (Note that these warnings are there to help you ...)
- I see that you have a libs folder. Make sure that your classpath is correctly set in the Manifest runtime tab. And that your .classpath file is consistent with your Manifest (Press 'update the classpath settings' in the Manifest overview tab).
Re: Eclipse exported Product file is not working. [message #1817813 is a reply to message #1817811] Fri, 29 November 2019 13:47 Go to previous message
Kirti Mahajan is currently offline Kirti MahajanFriend
Messages: 11
Registered: October 2019
Junior Member
Thanks. It is working fine now.
Previous Topic:Eclipse Plugin - Custom Builder
Next Topic:REST client within plugin
Goto Forum:
  


Current Time: Sun Oct 25 06:29:33 GMT 2020

Powered by FUDForum. Page generated in 0.02523 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top