Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OM2M » error in running OM2M
error in running OM2M [message #1817318] Wed, 20 November 2019 11:26 Go to next message
Fawzia Abujalala is currently offline Fawzia AbujalalaFriend
Messages: 2
Registered: November 2019
Junior Member
I am trying to run In-node on my Ubuntu 18 with java jdk 11.
I get the following error:

fawzia@fawzia-VirtualBox:~/org.eclipse.om2m/org.eclipse.om2m.site.in-cse/target/products/in-cse/linux/gtk/x86_64$ ./start.bat
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.eclipse.osgi.storage.FrameworkExtensionInstaller (file:/home/fawzia/org.eclipse.om2m/org.eclipse.om2m.site.in-cse/target/products/in-cse/linux/gtk/x86_64/plugins/org.eclipse.osgi_3.10.2.v20150203-1939.jar) to method java.net.URLClassLoader.addURL(java.net.URL)
WARNING: Please consider reporting this to the maintainers of org.eclipse.osgi.storage.FrameworkExtensionInstaller
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
osgi>
Re: error in running OM2M [message #1817406 is a reply to message #1817318] Thu, 21 November 2019 17:05 Go to previous messageGo to next message
Thierry Monteil is currently offline Thierry MonteilFriend
Messages: 32
Registered: November 2013
Location: Toulouse - France
Member
Hi,

try with a previous version of java or follow instuctions in the message to disable this warning.

Regards,

Thierry.
Re: error in running OM2M [message #1817439 is a reply to message #1817318] Fri, 22 November 2019 08:58 Go to previous message
Guillaume Garzone is currently offline Guillaume GarzoneFriend
Messages: 52
Registered: April 2015
Member
Unfortunately, due to retrocompatibility issues of Java since version 9, the OSGi container of OM2M does not work properly using Java 9 and above.
You should use the latest version of Java 8 to run the platform properly.
Previous Topic:Subscription deleted
Next Topic:Connect OM2M with MySQL
Goto Forum:
  


Current Time: Wed Dec 02 23:02:41 GMT 2020

Powered by FUDForum. Page generated in 0.02089 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top