Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Strange Menu Drawing Behavior With Exported RCP
Strange Menu Drawing Behavior With Exported RCP [message #1817201] Mon, 18 November 2019 13:49 Go to next message
Brandon Lewis is currently offline Brandon LewisFriend
Messages: 206
Registered: May 2012
Senior Member
I'm on Oxygen. I'm on a controlled linux system at my job and Oxygen is the last Eclipse version that is compatible with my GTK2 libs (of which I have no control over).

I've exported an Eclipse application with one of my plugins. My Product is set to org.eclipse.platform.ide and the Application is org.eclipse.ui.ide.workbench - bascially exporting Eclipse with my plugin bundled in.

I exported this with a Tycho/Maven build and all works well - except users get the Welcome to Eclipse! screen - which I want to remove.

Removing it seems to require an RCP.... okay... I'll get the benefit of possibly controlling the first active perspective and size etc...

I've since tried to create my own Product, but I've set the Application to org.eclipse.ui.ide.workbench - I don't want to throw the baby out with the bathwater as they say.

Strangely, on my linux system, the Menus are not drawn at all when the app launches. If I switch to another window and then back - then all the workbench menus appear. Or I can minimize the app, and once I unminimize, the menus will be present. Or I can almost re-paint the menu and toolbars with my mouse.

This happens only on the initial launch. All subsequent launches display the menus naturally as expected.

I have never seen this before.

Anyone ever seen this? I've tried to tweak with preWindowOpen and postWindowOpen, but of course, I've launch the org.eclipse.ui.ide.workbench Application so those have no effect.

If I launch my own Application, I now have two problems: 1) All the workbench menus I want are not there (because I'd have to add them with my RCP), but also 2) The menu items I do have don't appear initially, until I manipulate the window. So I still have my original problem - menus strangely don't get drawn on initial launch.

If I switch back to using the org.eclipse.platform.ide Product, all my menus appear as expected - yet so does the annoying Welcome screen.

Looks like I'm running Red Hat Linux Enterprise with GNOME 2.28.2

[Updated on: Mon, 18 November 2019 13:50]

Report message to a moderator

Re: Strange Menu Drawing Behavior With Exported RCP [message #1817699 is a reply to message #1817201] Thu, 28 November 2019 03:26 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 876
Registered: January 2012
Senior Member

I hazily recall similar behaviour if an exception occurred when populating menus such as might happen in a dynamic menu contribution?

Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:Secondary IDs broken?
Next Topic:Feasibility of swapping/swtiching between views when an event occurs
Goto Forum:
  


Current Time: Sun Oct 25 18:00:28 GMT 2020

Powered by FUDForum. Page generated in 0.01874 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top