Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » copy-paste now quotes the copied text . How to stop that?
copy-paste now quotes the copied text . How to stop that? [message #1816979] Wed, 13 November 2019 10:11 Go to next message
Ulrich Scholz is currently offline Ulrich ScholzFriend
Messages: 15
Registered: September 2013
Junior Member
After switching to the new version, copy-past via clipboard now quotes the copied text. So, if I copy part of a String literal including a surrounding double quote (i.e., text") the entered value is different (text\"). How to disable that?

Version: 2019-09 R (4.13.0)
Build id: 20190917-1200
Re: copy-paste now quotes the copied text . How to stop that? [message #1817898 is a reply to message #1816979] Mon, 02 December 2019 14:20 Go to previous message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 133
Registered: April 2012
Senior Member
You can disable this escaping by:
1. In the preferences menu deselect: Java > Editor > Typing > Escape text when pasting into a string literal
2. Disable smart insert mode: Edit > Smart Insert Mode [Ctrl+Shift+Insert]

See also https://bugs.eclipse.org/bugs/show_bug.cgi?id=522218
Previous Topic:Replacement for Action Set Part Association ?
Next Topic:how to get an open file's project name inside Eclipse
Goto Forum:
  


Current Time: Sun Jul 05 21:31:36 GMT 2020

Powered by FUDForum. Page generated in 0.02613 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top