Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Label alignment 'center' not working for svg workspace image style
Label alignment 'center' not working for svg workspace image style [message #1816850] Fri, 08 November 2019 10:44 Go to next message
Felix Dorner is currently offline Felix DornerFriend
Messages: 312
Registered: December 2015
Senior Member
I have some node mappings that use a workspace image style, pointing to svg graphics. I have set the label alignment to center, but the labels are aligned on the left when elements are created. Any ideas?
Re: Label alignment 'center' not working for svg workspace image style [message #1816932 is a reply to message #1816850] Tue, 12 November 2019 10:55 Go to previous message
Maxime Porhel is currently offline Maxime PorhelFriend
Messages: 476
Registered: July 2009
Location: Nantes, France
Senior Member
Hi Felix,

In org.eclipse.sirius.diagram.ui.internal.edit.parts.WorkspaceImageEditPart.refreshVisuals() it seems that the label alignment update is correctly called.
Do you have a simple reproduction case (a simple VSM on Ecore for example) ?

Regards,


Maxime Porhel - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius

Join the Sirius community at SiriusCon. Register for free: Nov. 9th Paris
http://www.siriuscon.org/
Previous Topic:Getting the source and target for displayed edges
Next Topic:Get selected item value in capella diagram
Goto Forum:
  


Current Time: Fri Feb 21 16:51:46 GMT 2020

Powered by FUDForum. Page generated in 0.02055 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top