Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Hawk » Can not select Neo4J Backend
Can not select Neo4J Backend [message #1816751] Wed, 06 November 2019 10:13 Go to next message
Sebastian Friedl is currently offline Sebastian FriedlFriend
Messages: 2
Registered: February 2019
Junior Member
Hello,

I want to use Hawk with a remote Neo4J database as backend, but cannot select Neo4J in Hawk view. Does anyone have an explanation for this?
I installed Hawk from the update page:
https://download.eclipse.org/hawk/1.2.0/updates/ and eclipse 2019-06

Regards
Sebastian

[Updated on: Wed, 06 November 2019 13:12]

Report message to a moderator

Re: Can not select Neo4J Backend [message #1816786 is a reply to message #1816751] Wed, 06 November 2019 20:20 Go to previous message
Antonio Garcia-Dominguez is currently offline Antonio Garcia-DominguezFriend
Messages: 524
Registered: January 2010
Location: Birmingham, UK
Senior Member

Hi Sebastian,

Due to the GPLv3 license of Neo4j, we cannot distribute the Neo4j support from the update site. You would have to build the Neo4j plugin from source yourself.

Regardless, Hawk only currently supports embedded Neo4j 2.x databases. Our roadmap for 1.3.0 is to support remote Neo4j 3.x databases through the Bolt protocol (the Bolt driver is Apache licensed), but first we want to release 1.2.0 (our first formal release in Eclipse).

Kind regards,
Antonio
Previous Topic:Behavoir in CRUD operations
Next Topic:How to use enums in EOL queries on EMF models?
Goto Forum:
  


Current Time: Sat Feb 22 02:30:34 GMT 2020

Powered by FUDForum. Page generated in 0.02328 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top