Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » inquiry about integration with GitHub Enterprise(GitHub)
inquiry about integration with GitHub Enterprise [message #1816044] Fri, 18 October 2019 00:47 Go to next message
Insu Jeong is currently offline Insu JeongFriend
Messages: 2
Registered: October 2019
Junior Member
I am using eclipse java v1.7.
I want to integrate with GitHub Enterprise.
But there is an error.

In my opinion, this is because of java version.(integration with eclipse support only more than java v1.8. if it is not please let me know.)
I am difficult to update to Java 1.8.

Could you please let me know integration with eclipse solution without update to Java 1.8?

My process was..
1. Eclipse Git
2. Select the menu "Clone a Git repository"
3. Enter the uri
4. Enter the Authentication (User, Password)
5. I got the error as attached image

And I attached the error screenshot.
If you need more info, please let me know.

Best Regards,
James
Re: inquiry about integration with GitHub Enterprise [message #1816082 is a reply to message #1816044] Sat, 19 October 2019 22:22 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3525
Registered: July 2009
Senior Member

Which version of Java and Eclipse is this? And why is an update to 1.8 difficult?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: inquiry about integration with GitHub Enterprise [message #1816096 is a reply to message #1816082] Mon, 21 October 2019 08:00 Go to previous messageGo to next message
Insu Jeong is currently offline Insu JeongFriend
Messages: 2
Registered: October 2019
Junior Member
Hi Nitin DahyabhaiFriend,

Thank you for your reply.

Eclipse version is 4.5.2.20160212-1500.(I attached image)
And Java version is 1.7.

And why is an update to 1.8 difficult?
Because my development environment is fit to 1.7 version.
And I'm collaborating with others, they are using same version.

Could you please help me?

Best Regards,
James
Re: inquiry about integration with GitHub Enterprise [message #1816107 is a reply to message #1816096] Mon, 21 October 2019 11:16 Go to previous message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 169
Registered: August 2016
Senior Member
That's a very old version: Eclipse Mars.2, which included EGit 4.1.1, which is 4 years old. There have been many improvements in EGit since then. The last EGit ("Eclipse Git") version that would have run on Java 1.7 is 4.5.x, which is still rather old. But you could try updating to EGit 4.5.0; use Help->Install new software with the update site https://download.eclipse.org/egit/updates-4.5/ .

But I'd really recommend updating your JVM for running Eclipse to Java 11; at the very least to Java 1.8, and upgrading to a newer Eclipse (for instance 2019-06), and installing a modern EGit (I'd suggest EGit 5.5.1). You can still configure Eclipse to compile and build your Java code against Java 1.7.

If you absolutely need to stick with that old Eclipse Mars.2 version, at least install Java 1.8 and use it to run that Eclipse. Configure it to compile and build against Java 1.7. Then install EGit 5.2.0. That's the last version of EGit that will run on that old Eclipse if you use Java 1.8, and at least this will bring your setup halfway up to date.

[Updated on: Mon, 21 October 2019 11:34]

Report message to a moderator

Previous Topic:How to add multiple e-mail addresses to eclipse.org profile?
Next Topic:Eclipse RCP-Plug-in "com.masterdemo" was unable to instantiate class com.master.rcp.Master
Goto Forum:
  


Current Time: Fri Nov 15 15:03:34 GMT 2019

Powered by FUDForum. Page generated in 0.03493 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top