Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Lost on first try(Arduino compatible code)
Lost on first try [message #1815995] Wed, 16 October 2019 17:20 Go to next message
ullix U is currently offline ullix UFriend
Messages: 2
Registered: October 2019
Location: Germany
Junior Member
I installed eclipse a few hours ago, installed the ESP32 platform successfully (I believe) and fail in the most trivial attempt to setup an Arduino sketch, let alone any ones.

#include <Arduino.h>

void setup() {
Serial.begin(115200);
delay(1000);
}

void loop() {
}

It tells me that functions delay and Serial cannot be resolved. What else is it that I need to install???
Re: Lost on first try [message #1815996 is a reply to message #1815995] Wed, 16 October 2019 17:22 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3525
Registered: July 2009
Senior Member

You might try the the CDT-specific group: http://www.eclipse.org/forums/eclipse.tools.cdt , as all of the Arduino-like device programming and board support is built on the CDT.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Losing Saved Perspectives - Please Help!
Next Topic:Unable to launch Eclipse in Ubuntu
Goto Forum:
  


Current Time: Fri Nov 15 15:34:10 GMT 2019

Powered by FUDForum. Page generated in 0.03633 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top