Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Installer closes immediately after the splash screen with no error message
Eclipse Installer closes immediately after the splash screen with no error message [message #1815758] Wed, 09 October 2019 23:55 Go to next message
Daniel REDACTED is currently offline Daniel REDACTEDFriend
Messages: 3
Registered: October 2019
Junior Member
I've been trying to install Eclipse, but the installer keeps crashing immediately after the splash screen with no error messages. The only thing it does is generate a javacore text file, a dmp file, and a trc file.

Things I've tried:
- Running the installer as Administrator
- Running the installer from the command prompt
- Redownloading the installer
- Running the installer from a different directory

I've already tried Googling this problem , and got nothing. I've also attached two of the three files it generated. I can't attach the third file cause it's well over the size limit.
Re: Eclipse Installer closes immediately after the splash screen with no error message [message #1815760 is a reply to message #1815758] Thu, 10 October 2019 05:37 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30691
Registered: July 2009
Senior Member
It appears that you're using C:\Program Files\AdoptOpenJDK\jdk-8.0.222.10-openj9\jre as your Java implementation and that it croaks to produce a dump that a don't know how to interpret. :-(

You can directly download a package from https://www.eclipse.org/downloads/packages/ and try to run that, but the installer is just an Eclipse application so if the installer won't run on that JVM and it's likely that Eclipse itself won't run on that JVM either, but it's worth a try.

Please report back on your success or failure with unzipping a package and the use of openj9 for the purpose of running Eclipse itself.
Re: Eclipse Installer closes immediately after the splash screen with no error message [message #1815789 is a reply to message #1815760] Thu, 10 October 2019 18:44 Go to previous messageGo to next message
Daniel REDACTED is currently offline Daniel REDACTEDFriend
Messages: 3
Registered: October 2019
Junior Member
Just downloaded and unzipped a package. The program lets me choose a workspace directory, but afterwords closes on the welcome page thing with zero error messages.
Re: Eclipse Installer closes immediately after the splash screen with no error message [message #1815796 is a reply to message #1815789] Fri, 11 October 2019 03:38 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30691
Registered: July 2009
Senior Member
When you say it closes on the welcome page, you mean it crashes and doesn't work or that it works fine after this point with no problems? If there are problems, the <workspace>/.metadata/.log should contain information about what has gone wrong; but if you see the welcome page, it got pretty far. If it didn't work, please attach the .log; I can probably find someone knowledgeable about openj9 to have a look at the problems you're having.
Re: Eclipse Installer closes immediately after the splash screen with no error message [message #1815797 is a reply to message #1815796] Fri, 11 October 2019 03:54 Go to previous messageGo to next message
Daniel REDACTED is currently offline Daniel REDACTEDFriend
Messages: 3
Registered: October 2019
Junior Member
It basically freezes on the welcome screen for a few seconds before crashing without showing any error messages. I've attached the javacore text file it generated plus the log file from the eclipse workspace directory.
Re: Eclipse Installer closes immediately after the splash screen with no error message [message #1815798 is a reply to message #1815797] Fri, 11 October 2019 05:23 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30691
Registered: July 2009
Senior Member
I've forwarded your note to some people who hopefully can help. At this point all I can say is that these all work well:

https://download.eclipse.org/oomph/jre/index-handler.php?vm=1_0_8

I was under the impression that OpenJDK's j9 should also work well, but apparently there is an issue with that...
Re: Eclipse Installer closes immediately after the splash screen with no error message [message #1815832 is a reply to message #1815798] Fri, 11 October 2019 17:21 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30691
Registered: July 2009
Senior Member
The response I got with regard to this issue is "First thing I'd suggest is to switch to a latest JRE. If it is not working, they should use the official channel at AdoptOpenJDK." I assume this implies there is a newer version available that might have fixed the problems you see. If that's not the case, it would be good to report the problem at the site from which you downloaded this JDK. It's definitely a JRE-specific problem; a JRE should not crash like this...
Previous Topic: This code multiple times automatically
Next Topic:edi for assembler
Goto Forum:
  


Current Time: Thu Dec 12 08:42:36 GMT 2019

Powered by FUDForum. Page generated in 0.04115 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top