Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Team Foundation Server - Eclipse and Cross Platform: Unable to clone Git repository using TEE in Ecl(Eclipse IDE for Enterprise Java Developers Version 2019-06 (4.12.0).)
Team Foundation Server - Eclipse and Cross Platform: Unable to clone Git repository using TEE in Ecl [message #1815560] Sat, 05 October 2019 00:23 Go to next message
Ahetejazahmad Khan is currently offline Ahetejazahmad KhanFriend
Messages: 2
Registered: October 2019
Junior Member
Hello Team,

I have TFS 2018.2 and Eclipse IDE for Enterprise Java Developers Version 2019-06 (4.12.0). In eclipse I have installed Team Explorer Everywhere plugin and I am able to see all my Git repository however when I try to clone a git repository using the administrator account in TFS I get below error:
Error cloning the <GitName> repository: not authorized.
Clone Error:
Please find attachment.

Eclipse Version:
Please find attachment.


In case if the question is placed in the wrong forum path feel free to correct it.

Thank you.
Re: Team Foundation Server - Eclipse and Cross Platform: Unable to clone Git repository using TEE in [message #1815563 is a reply to message #1815560] Sat, 05 October 2019 06:02 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
It's probably best to ask on the EGit forum:

https://www.eclipse.org/forums/index.php?t=thread&frm_id=48

If the repo you access requires authentication that I doubt an http: URI will work. Likely you'd need https, and likely somewhere you'd need to specify your use ID. Without seeing anything about the URI you're using, it's likely folks won't be able to provide much help. Likely you'd be better to use ssh: instead...
Re: Team Foundation Server - Eclipse and Cross Platform: Unable to clone Git repository using TEE in [message #1815719 is a reply to message #1815563] Tue, 08 October 2019 19:46 Go to previous message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 161
Registered: August 2016
Senior Member
Additionally note that TEE (Team Explorer Everywhere) is no longer maintained: https://github.com/microsoft/team-explorer-everywhere .

You could try using normal EGit. It is already included in the Eclipse version you use. If you can't get it to work with EGit: well, TFS has some quirks. See https://www.eclipse.org/forums/index.php?t=msg&th=1100497&goto=1814538&#msg_1814538 for some hints.
Previous Topic:Sirius validation issues with newValue / selection input
Next Topic:best way to configure my project
Goto Forum:
  


Current Time: Sun Oct 20 05:59:04 GMT 2019

Powered by FUDForum. Page generated in 0.03090 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top