Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Why the setting of a property as message argument is not available?
Why the setting of a property as message argument is not available? [message #1814670] Mon, 16 September 2019 08:51 Go to next message
Yoann Farre is currently offline Yoann FarreFriend
Messages: 116
Registered: November 2017
Senior Member
Hello,

I commonly use the field "Argument" of a Message and I use LiteralString or EnumerationLiteral elements as argument. But I don't understand why we cannot use a property (contained in a classifier) as argument of a Message.

As an instance specification is not related to a property, it seems not to be a good solution to do that.

Could I have some explanation about that feature and why Property is not permitted? And maybe the good way to model a message having an operation with arguments as signature and to specify the arguments to use?

Regards.

Yoann.
[Duplicated post] [message #1814672 is a reply to message #1814670] Mon, 16 September 2019 08:54 Go to previous message
Yoann Farre is currently offline Yoann FarreFriend
Messages: 116
Registered: November 2017
Senior Member
Sorry for the duplicated post.

[Updated on: Mon, 16 September 2019 08:57]

Report message to a moderator

Previous Topic:[Duplicated post]
Next Topic:Links to model elements in requirement
Goto Forum:
  


Current Time: Sat Dec 14 23:43:51 GMT 2019

Powered by FUDForum. Page generated in 0.01857 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top