Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » RAD crashes during Oomph initial setup configuration(RAD crashes during Oomph initial setup configuration)
RAD crashes during Oomph initial setup configuration [message #1814147] Wed, 04 September 2019 17:56 Go to next message
Rohit Oberoi is currently offline Rohit OberoiFriend
Messages: 1
Registered: September 2019
Junior Member
Hello Oomph Team,

I used Oomph in Eclipse environments to retain / sync preferences and I liked it. Recently, we're using IBM Rational Application Developer (RAD) tool v9.6.1.3 for a project. It so happens that the Oomph plug-in isn't built into RAD though it's based on Eclipse v4.6.3 (Neon).

Problem:
    I grabbed the latest update site of Oomph and installed into RAD. With few exclusions it gets installed and I can see the record preferences option.

    When I traverse the following path on RAD, it just crashes: Window > Preferences > Oomph > Java Virtual Machines

    I also try to record the preferences, and Oomph basically traverses all the nodes in preferences tree, and when it encountered Oomph > Java Virtual Machines, it crashed.

    Please note that IBM RAD is configured with IBM Java, and not Oracle / Open JDK.

    I believe Oomph either requires Oracle Java, or there's some dependency on Eclipse framework, which isn't checked during prerequisite, and fails at runtime.


Can you please help? I'm really missing this plug-in under RAD. Is there anyway to remove the JVM node under Oomph?

Cheers,
Re: RAD crashes during Oomph initial setup configuration [message #1814406 is a reply to message #1814147] Wed, 11 September 2019 05:25 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30911
Registered: July 2009
Senior Member
What do you mean by "crashes"? The whole JVM dies? Nothing is logged in the Error log to provide clues? The JRE support on Windows uses a native DLL (to look in the system registry for registered Java versions, so perhaps there is some issue with how that DLL works with the IBM JVM... Does the installer itself work? It uses the JRE support as well...
Previous Topic:Defining source and Javadoc location for JRE task
Next Topic:Copyright-consistency management tool question
Goto Forum:
  


Current Time: Wed Feb 26 20:44:59 GMT 2020

Powered by FUDForum. Page generated in 0.05557 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top