Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Autagent does not clean temp files(Autagent does not clean temp files)
Autagent does not clean temp files [message #1814085] Tue, 03 September 2019 10:17 Go to next message
Stephan Svoboda is currently offline Stephan SvobodaFriend
Messages: 2
Registered: September 2019
Junior Member
Automated tests broke because test machines disk space was fully used by folders created in c:\users\%username%\.jubula folder each time autagent.exe and stopautagent.exe were called by test automation scripts.

%USER%\.jubula\configAreas\autagent\8.7.1.046\org.eclipse.osgi
4 folders created on calling autagent.exe
4 folders created on calling stopautagent.exe

The folders have path like c:\users\%username%\.jubula\configAreas\autagent\8.7.1.046\org.eclipse.osgi\123

None of this folders is cleaned or deleted ever
It seems this is a new behavior since 8.7 because we have only a small number of created folders in the old version folders. Behavior was not recognized earlier because it needed time to fill the disk.

EDIT:
Happens on Win7 and Win10 systems

[Updated on: Thu, 05 September 2019 07:45]

Report message to a moderator

Re: Autagent does not clean temp files [message #1814354 is a reply to message #1814085] Tue, 10 September 2019 06:44 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
Hello, thanks for the Information.
We have the same behavior on our Machines. But i know this was also in old versions, but maybe not that excessive.

Which version do you had before?

Because we have not changed anything in there since a longer time. Maybe in platform there was some changes.

best regards
Marvin Mueller
Re: Autagent does not clean temp files [message #1815481 is a reply to message #1814354] Thu, 03 October 2019 10:27 Go to previous messageGo to next message
Stephan Svoboda is currently offline Stephan SvobodaFriend
Messages: 2
Registered: September 2019
Junior Member
Sorry for late replay we are curently using jubula_8.7.1.046
Versions before without the issue were: jubula_8.6.0.262 and jubula_8.5.0.127

Further analyzation shows that many maybe all folders have a .DELETE file within them which seems to be a marker for deletion which is not executed.

KR

Stephan Svoboda
Re: Autagent does not clean temp files [message #1815688 is a reply to message #1815481] Tue, 08 October 2019 13:03 Go to previous message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
No Problem,

i could reproduce the problem, but could not fix it at this moment. If this is a bigger problem for you, you can do a workaround. In the "autagent.ini" you can add the "-clean" argument(e.g. after "-consolelog")

best regards
Marvin Mueller
Previous Topic:JAVA Swing UI automate the application testing
Next Topic:Testing of AUT launched from another AUT
Goto Forum:
  


Current Time: Sun Nov 17 14:56:09 GMT 2019

Powered by FUDForum. Page generated in 0.02123 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top