Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » org.eclipse.fx.ui.workbench.fx not found(requires 'osgi.bundle; org.eclipse.fx.ui.workbench.fx 0.0.0' but it could not be found)
org.eclipse.fx.ui.workbench.fx not found [message #1811265] Thu, 29 August 2019 19:34
Samuel Abramov is currently offline Samuel AbramovFriend
Messages: 3
Registered: August 2019
Junior Member
Hello guys,

I have a pom less structure as described in vogella tycho tutorial.

This is my structure:
https://www.vogella.com/tutorials/EclipseTycho/img/xtychosetup10.png.pagespeed.ic.nl4kXVHOvy.png

My javafx e4 project starts via Eclipse without any error logs or problems.

But when I execute
mvn clean verify


on project location.

I got:

Missing requirement: my.rcp.app 1.0.0 requires 'osgi.bundle; org.eclipse.fx.ui.workbench.fx 3.6.0' but it could not be found

I dont understand this error because my.rcp.app Manifest includes

org.eclipse.fx.ui.workbench.fx

Do I need to add a org.eclipse.fx.ui.workbench.fx dependency somewhere else than in my rcp bundle?

Any ideas?

Update

I actually created new JavaFX RCP from scratch with e(fx)clipse plugin.

There is exact same behavior. I can start the RCP Application inside Eclipse IDE but running mvn clean verify in releng folder result in same org.eclipse.fx.ui.workbench.fx error





[Updated on: Fri, 30 August 2019 19:44]

Report message to a moderator

Previous Topic:How is the process to announce new efxclipse releases?
Next Topic:No Default Proposals
Goto Forum:
  


Current Time: Mon Nov 18 09:58:56 GMT 2019

Powered by FUDForum. Page generated in 0.01781 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top