Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dynamic Languages Toolkit (DLTK) » ruby DLTK updates errors on oxygen
ruby DLTK updates errors on oxygen [message #1811220] Thu, 29 August 2019 01:44 Go to next message
Vincent Jong is currently offline Vincent JongFriend
Messages: 2
Registered: August 2019
Junior Member
Originally, I had EGit and ruby DLTK updates that conflicted and I updated seperately starting with EGit that installed fine. Now, The errors in upgrading ruby DLTK errors with:

An error occurred while collecting items to be installed
session context was:(profile=_Users_vjong_eclipse_java-2019-06_Eclipse.app_Contents_Eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.abstractdebugger.source,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.activestatedebugger.source,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.basicdebugger.source,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.core.source,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.debug.source,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.debug.ui.source,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.fastdebugger.source,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.formatter.source,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.launching.source,5.10.0.201808292040
No repository found containing: org.eclipse.update.feature,org.eclipse.dltk.ruby.sdk,5.10.0.201808292040
No repository found containing: binary,org.eclipse.dltk.ruby.sdk_root,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.testing.source,5.10.0.201808292040
No repository found containing: osgi.bundle,org.eclipse.dltk.ruby.ui.source,5.10.0.201808292040


Is there any workaround available? I've been hesitant to uninstall and reinstalling DLTK because the error seems like it maybe due to installing individually and having EGit successfully install... which might cause reinstall of DLTK to fail. Has any one else seen this?

Dynamic Languages Toolkit - Ruby Development Tools 5.11.0.201811220629
Dynamic Languages Toolkit - Ruby Development Tools SDK 5.10.0.201808292040

Those are the packages that are attempting to be update to.
Re: ruby DLTK updates errors on oxygen [message #1811261 is a reply to message #1811220] Thu, 29 August 2019 17:54 Go to previous message
Vincent Jong is currently offline Vincent JongFriend
Messages: 2
Registered: August 2019
Junior Member
I broke down and uninstalled both packages reinstalled ruby DLTK through marketplace... The install went fine and then I checked for updates and that went fine as well...
Previous Topic:old jruby version in dltk/org.eclipse.dltk.ruby
Next Topic:[BUILD] I-I200811050923-200811050923
Goto Forum:
  


Current Time: Sat Oct 31 02:34:50 GMT 2020

Powered by FUDForum. Page generated in 0.01804 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top