Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » Problem using KURA Client to connect to AWS IoT(Unknown.Ug<IP Address of my Device>/kura line 9 > scriptElement))
Problem using KURA Client to connect to AWS IoT [message #1810833] Tue, 20 August 2019 10:33 Go to next message
Mike McKean is currently offline Mike McKeanFriend
Messages: 3
Registered: August 2019
Junior Member
index.php/fa/36139/0/Hi,

I am trying to connect using KURA 3.20 on a Raspberry Pi, to AWS IoT. To try and help you, I attached a screenshot of the error message, but it is;

Failed to connect! Please review your configuration and try again later.

Show Stack Trace

Unknown.Ug<IP Address of my Device>/kura line 9 > scriptElement)
Unknown.ah<IP Address of my Device>/kura line 9 > scriptElement)
etc

Any help would be appreciated.
Thanks
Mike
index.php/fa/36139/0/
Re: Problem using KURA Client to connect to AWS IoT [message #1810837 is a reply to message #1810833] Tue, 20 August 2019 11:38 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 393
Registered: July 2015
Location: Italy
Senior Member
Hi,
did you try to follow this guide? http://eclipse.github.io/kura/cloud-stacks/kura-aws-cloud.html

Eventually, you can have a look at the kura.log and kura-console.log files in /var/log to try to see if there is a meaningful error there.

Best regards,
Matteo
Re: Problem using KURA Client to connect to AWS IoT [message #1810916 is a reply to message #1810837] Thu, 22 August 2019 03:36 Go to previous message
Mike McKean is currently offline Mike McKeanFriend
Messages: 3
Registered: August 2019
Junior Member
Hi
I have used this Raspberry Pi with KURA to connect previously to my Eurotech Sanbox account. But I just cannot get it to connect to AWS. As you suggested I have checked the logs.

Note. I have already, very carefully followed these instructions.. thanks .. http://eclipse.github.io/kura/cloud-stacks/kura-aws-cloud.html I am using KURA 3.2, and everything is set-up. I had no errors.

In terms of the logs;
The KURA log has nothing in it, since I last connected to Eurotech. I have deleted my "Eurotech" config details. So, I am now only using One Connection to AWS, as per the above instructions. The kura-console.log has recent log details, as below. I have included a few connection attempts from the past few days. Can you see what's wrong?

!ENTRY org.eclipse.equinox.ds 1 0 2019-08-20 20:18:06.620
!MESSAGE Could not bind a reference of component org.eclipse.kura.net.admin.NetworkConfigurationService. The reference is: Reference[name = ModemManagerService, interface = org.eclipse.kura.net.admin.modem.ModemManagerService, policy = dynamic, cardinality = 0..1, target = null, bind = setModemManagerService, unbind = unsetModemManagerService]
Kura Started (pid=338) ...
!SESSION 2019-08-21 14:54:10.916 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_222
java.vendor=Raspbian
BootLoader constants: OS=linux, ARCH=arm, WS=gtk, NL=en_GB
Command-line arguments: -configuration /tmp/.kura/configuration -console 5002 -consoleLog

!ENTRY org.eclipse.equinox.ds 1 0 2019-08-21 14:54:24.151
!MESSAGE Could not bind a reference of component org.eclipse.kura.core.configuration.CloudConfigurationHandler. The reference is: Reference[name = CloudService, interface = org.eclipse.kura.cloud.CloudService, policy = dynamic, cardinality = 0..1, target = (kura.service.pid=org.eclipse.kura.cloud.CloudService), bind = setCloudService, unbind = unsetCloudService]

!ENTRY org.eclipse.equinox.ds 1 0 2019-08-21 14:54:25.106
!MESSAGE Could not bind a reference of component org.eclipse.kura.core.deployment.hook.DeploymentHookManager. The reference is: Reference[name = DeploymentHook, interface = org.eclipse.kura.deployment.hook.DeploymentHook, policy = dynamic, cardinality = 0..n, target = null, bind = bindHook, unbind = unbindHook]

!ENTRY org.eclipse.equinox.ds 1 0 2019-08-21 14:54:29.807
!MESSAGE Could not bind a reference of component org.eclipse.kura.net.admin.NetworkConfigurationService. The reference is: Reference[name = ModemManagerService, interface = org.eclipse.kura.net.admin.modem.ModemManagerService, policy = dynamic, cardinality = 0..1, target = null, bind = setModemManagerService, unbind = unsetModemManagerService]

!ENTRY org.eclipse.equinox.ds 2 0 2019-08-22 03:50:48.003
!MESSAGE [SCR] Enabling components of bundle org.eclipse.kura.web2 did not complete in 60000 ms
Previous Topic:Auto create driver instance, assets and channels
Next Topic:Docker Re-Building fails due to cp: cannot stat '/context/bin/*'
Goto Forum:
  


Current Time: Tue Jul 07 07:35:47 GMT 2020

Powered by FUDForum. Page generated in 0.01804 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top