Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Launch Product with GTK2 form Eclipse started with GTK3(Is it possible to launch Product with GTK2 form Eclipse started with GTK3)
Launch Product with GTK2 form Eclipse started with GTK3 [message #1809835] Wed, 24 July 2019 10:08 Go to next message
Artur Wystub is currently offline Artur WystubFriend
Messages: 1
Registered: August 2016
Junior Member
My product runs under Linux and needs GTK2.

So when I put:

openFile
--launcher.GTK_version
2

in my eclipse.ini, then I can launch my product directly from eclipse workspace, but when I put:

openFile
--launcher.GTK_version
3

in my eclipse.ini, then I get errors about problems with gtk3.

So my question is:

Is it possible to start Eclipse in gtk3 mode, and the somehow configure the launcher to use gtk2 for my product. I would like to run Eclipse with gtk3, because under gtk2 i get ugly display errors when editing or scrolling. And I need my product to use gtk2, because I use the Mozilla SWT component.
Re: Launch Product with GTK2 form Eclipse started with GTK3 [message #1809925 is a reply to message #1809835] Thu, 25 July 2019 18:15 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
No, newer versions of Eclipse dropped GTK 2 support.
Previous Topic:Parameter Variable
Next Topic:SWT libraries missing from install
Goto Forum:
  


Current Time: Mon Oct 21 04:45:28 GMT 2019

Powered by FUDForum. Page generated in 0.02881 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top