Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Buildship plug-in: Cannot complete the install because of a conflicting dependency.
Buildship plug-in: Cannot complete the install because of a conflicting dependency. [message #1809616] Thu, 18 July 2019 20:45 Go to next message
L C is currently offline L CFriend
Messages: 9
Registered: January 2019
Junior Member
Hi,

Am trying to upgrade Buildship plug-in by clicking "Upgrade" button in the "Installed plug-ins" tab but getting the error below.

Any ideas how to fix this? Thanks

Software being installed: Buildship: Eclipse Plug-ins for Gradle 3.1.1.v20190701-1623 (org.eclipse.buildship.feature.group 3.1.1.v20190701-1623)
  Software currently installed: Buildship: Eclipse Plug-ins for Gradle 3.1.0.v20190501-0830 (org.eclipse.buildship.feature.group 3.1.0.v20190501-0830)
  Only one of the following can be installed at once: 
    Buildship, Eclipse Plug-ins for Gradle - UI 3.0.1.v20181217-1554 (org.eclipse.buildship.ui 3.0.1.v20181217-1554)
    Buildship, Eclipse Plug-ins for Gradle - UI 3.1.1.v20190701-1623 (org.eclipse.buildship.ui 3.1.1.v20190701-1623)
    Buildship, Eclipse Plug-ins for Gradle - UI 3.1.0.v20190501-0830 (org.eclipse.buildship.ui 3.1.0.v20190501-0830)
  Cannot satisfy dependency:
    From: Buildship: Eclipse Plug-ins for Gradle 3.1.0.v20190501-0830 (org.eclipse.buildship.feature.group 3.1.0.v20190501-0830)
    To: org.eclipse.equinox.p2.iu; org.eclipse.buildship.ui [3.1.0.v20190501-0830,3.1.0.v20190501-0830]
  Cannot satisfy dependency:
    From: Buildship: Eclipse Plug-ins for Gradle 3.1.1.v20190701-1623 (org.eclipse.buildship.feature.group 3.1.1.v20190701-1623)
    To: org.eclipse.equinox.p2.iu; org.eclipse.buildship.ui [3.1.1.v20190701-1623,3.1.1.v20190701-1623]
Re: Buildship plug-in: Cannot complete the install because of a conflicting dependency. [message #1809659 is a reply to message #1809616] Fri, 19 July 2019 13:58 Go to previous message
L C is currently offline L CFriend
Messages: 9
Registered: January 2019
Junior Member
Upgrading to 2019-6R from 2019-3R resolved the issue for me.
Previous Topic:Oracle DataBase Tools New Connection Profile Error
Next Topic:stuck creating Java ME MIDlet (SOLVED)
Goto Forum:
  


Current Time: Mon Oct 21 04:38:10 GMT 2019

Powered by FUDForum. Page generated in 0.02572 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top