Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to install gradle in runtime eclipse(Gradle is not installing in runtime eclipse using target platform)
Unable to install gradle in runtime eclipse [message #1809551] Thu, 18 July 2019 05:59 Go to next message
Veerababu  Maragani is currently offline Veerababu MaraganiFriend
Messages: 8
Registered: June 2019
Junior Member
I added the update site for gradle in target definition file but it is not installing gradle in runtime eclipse. The url which I used is as follows:-
http://download.eclipse.org/buildship/updates/e411/releases/3.x
In runtime eclipse I went to Window->Show View->Other then searched for gradle but did not find it. Please tell if I'm doing any mistake.
Re: Unable to install gradle in runtime eclipse [message #1809556 is a reply to message #1809551] Thu, 18 July 2019 07:25 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30372
Registered: July 2009
Senior Member
You use such a site with Help -> Install New Software...
Re: Unable to install gradle in runtime eclipse [message #1809561 is a reply to message #1809556] Thu, 18 July 2019 09:01 Go to previous messageGo to next message
Veerababu  Maragani is currently offline Veerababu MaraganiFriend
Messages: 8
Registered: June 2019
Junior Member
Actually my requirement is we want to give the buildship gradle support to our RCP Product for that purpose we have added updatesite url (http://download.eclipse.org/buildship/updates/e411/releases/3.x) in that target definition file and downloaded the required plugins, but when we are trying to run the applications ,i am getting the errors related to bundle version for the below plugins
com.google.gson ,com.google.guava and
org.gradle.toolingapi ,
please find the attachment and guide me how to resolve these errors
index.php/fa/35955/0/
Re: Unable to install gradle in runtime eclipse [message #1809648 is a reply to message #1809561] Fri, 19 July 2019 09:50 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30372
Registered: July 2009
Senior Member
You'll need to ensure that those too are in your target platform and that their containing bundles are deployed by your launch configuration.
Re: Unable to install gradle in runtime eclipse [message #1809717 is a reply to message #1809648] Mon, 22 July 2019 05:10 Go to previous messageGo to next message
Veerababu  Maragani is currently offline Veerababu MaraganiFriend
Messages: 8
Registered: June 2019
Junior Member
Hi Ed Merks,
Thanks for your quick response ,I verified but those plugins are not available in target platform ,could you please let me know in which updatesites those plugins are available ?
Re: Unable to install gradle in runtime eclipse [message #1809719 is a reply to message #1809717] Mon, 22 July 2019 06:34 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30372
Registered: July 2009
Senior Member
You can use this tool to find a repository:

https://wiki.eclipse.org/Eclipse_Oomph_Authoring#How_to_find_a_P2_repository_at_Eclipse_using_the_Repository_Explorer
Previous Topic:mark Asterisk (*** )
Next Topic:Eclipse new Menu Creation Plugin
Goto Forum:
  


Current Time: Fri Aug 23 09:47:23 GMT 2019

Powered by FUDForum. Page generated in 0.03331 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top