Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » cannot upgrade papyrus ide
cannot upgrade papyrus ide [message #1809473] Tue, 16 July 2019 16:37 Go to next message
nimo mayr is currently offline nimo mayrFriend
Messages: 13
Registered: April 2019
Junior Member
I have Payprus IDE installed with the following version:

Version: 2019-03 (4.11)

and want to upgrade to version 4.4 and I added the update site:
"http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/2019-06"

to "available update sites".

However, when I select the the items for update (papyrus 4.4), then IDE says:
"a newer version is already installed." But this is not true, actually I have the older version (2019-03 (4.11) installed.

How can I upgrade papyrus ide?
Re: cannot upgrade papyrus ide [message #1809514 is a reply to message #1809473] Wed, 17 July 2019 08:54 Go to previous messageGo to next message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 47
Registered: September 2014
Location: Paris Saclay, France
Member
Hi Nimo,

I am a bit confused by how you ended up like that. By Papyrus IDE do you mean the RCP corresponding to the 4.3.0 release ?
Could you link a screenshot/txt file of your 'installation details> installed features' so as to get a better idea of your setup and the Papyrus version (not the IDE/RCP listed version) ? (there is, by default, an update site to the nightly version of papyrus so you might have checked out that one before.)

Then again, even if the RCP was configured to be upgradable (on the Papyrus end of things) the platform/ide itself was not designed to be. so it might end up breaking your installation depending on the evolutions of the released material.
You might be better off downloading the latest RCP and setting/migrating your workspace to it.

HTH,
Quentin
Re: cannot upgrade papyrus ide [message #1809522 is a reply to message #1809514] Wed, 17 July 2019 09:39 Go to previous messageGo to next message
nimo mayr is currently offline nimo mayrFriend
Messages: 13
Registered: April 2019
Junior Member
Hello,

yes, I mean "RCP". I wanted to upgrade the RCP (which is: 2019-03 release (4.3.0)) to RCP (2019-06 release (4.4.0))
by "Help->Install New Software-> with the added update site: "http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/2019-06"

Quote:
You might be better off downloading the latest RCP and setting/migrating your workspace to it.


I wanted to avoid this. Why can I not upgrade from IDE? It s annoying to download and set up new RCP manually each time.

Normally, when user clicks "Help->Check for updates", then user expects that updates (as well as upgrades) are manged by RCP itself. Why should I do that manually?

[Updated on: Wed, 17 July 2019 09:40]

Report message to a moderator

Re: cannot upgrade papyrus ide [message #1809525 is a reply to message #1809522] Wed, 17 July 2019 11:28 Go to previous messageGo to next message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 47
Registered: September 2014
Location: Paris Saclay, France
Member

The RCP was meant to provide an all in one installation for the specific release. That is with everything already installed with the bits used for the GA release.
If you want to update it you could _but_ as eclipse cannot know the future releases of the installed components you would have to manually add the necessary update sites and therefore I fail to see the benefits of doing it through an RCP.

You would be better either installing what you want through Oomph and the Papyrus setup file or doing it from scratch.

HTH,
Quentin

Ps: btw, looking at your latest screenshot you do have a more recent version of Papyrus than the 4.4.0 (2019-06) as you have updated it to the nightly 4.5.0.
Re: cannot upgrade papyrus ide [message #1809555 is a reply to message #1809525] Thu, 18 July 2019 07:23 Go to previous message
nimo mayr is currently offline nimo mayrFriend
Messages: 13
Registered: April 2019
Junior Member
Thanks for your help.

Yes, 4.5 is the newer one, however,. I also want to update this component:

Papyrus	4.3.0.201903261150	org.eclipse.papyrus.rcp.product 


by using the nightly update site.

The actual version must be higher than 4.3.X.
The update site "http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master/" does not provide a newer version than 4.3.

So which update site should I use to upgrade ALL the papyrus components?

[Updated on: Thu, 18 July 2019 07:24]

Report message to a moderator

Previous Topic:Syncing UML class diagram
Next Topic:Execute Multiple model using Moka
Goto Forum:
  


Current Time: Mon Dec 16 02:57:17 GMT 2019

Powered by FUDForum. Page generated in 0.01370 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top